CVE-2026-55584
CVE-2026-55584 · phpSysInfo: IP allowlist (PSI_ALLOWED) bypass via spoofed X-Forwarded-For / Client-IP headers
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
phpSysInfo is a customizable PHP script that displays system information. Prior to 3.4.6, the PSI_ALLOWED access-control check in read_config.php trusts attacker-controlled X-Forwarded-For and Client-IP HTTP headers before REMOTE_ADDR. A remote unauthenticated attacker can supply an allowed address in one of these headers to impersonate a trusted client and access exposed hostname, kernel, CPU, memory, filesystem, and network-interface information. This issue is fixed in version 3.4.6.
CVSS 7.5 · Alta · EPSS 1,9% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
phpsysinfo
- Versiones
- < 3.4.6: Afectada
Sin corrección publicada
phpsysinfo Debian:12
- Versiones
- 3.4.2-3
- 3.4.3-1
- 3.4.3-2
- 3.4.3-3
- 3.4.4-1
- 3.4.4-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo Debian:13
- Versiones
- 3.4.4-1
- 3.4.4-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo Debian:14
- Versiones
- 3.4.4-1
- 3.4.4-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo/phpsysinfo Packagist
- Versiones
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.2.0
- v3.2.1
- v3.2.10
- v3.2.2
- v3.2.3
- v3.2.4
- v3.2.5
- v3.2.6
- v3.2.7
- v3.2.8
- v3.2.9
- v3.3.0
- v3.3.1
- v3.3.2
- v3.3.3
- v3.3.4
- v3.4.0
- v3.4.1
- v3.4.2
- v3.4.3
- v3.4.4
- v3.4.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.4.6
Actualiza a 3.4.6
phpsysinfo Ubuntu:16.04:LTS
- Versiones
- 3.0.17-1ubuntu1
- 3.2.1-1ubuntu1
- 3.2.1-1ubuntu2
- 3.2.1-1ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo Ubuntu:18.04:LTS
- Versiones
- 3.2.5-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo Ubuntu:20.04:LTS
- Versiones
- 3.2.5-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo Ubuntu:22.04:LTS
- Versiones
- 3.2.5-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo Ubuntu:24.04:LTS
- Versiones
- 3.4.3-1
- 3.4.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo Ubuntu:26.10
- Versiones
- 3.4.4-1
- 3.4.4-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
phpsysinfo Ubuntu:26.04:LTS
- Versiones
- 3.4.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada