p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de phpsysinfo

Vulnerabilidades publicadas para phpsysinfo en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 9

  1. CVE-2026-55584

    Alta · CVSS 7.5EPSS 1,91%Código de explotación públicoSin corrección publicada

    phpSysInfo: IP allowlist (PSI_ALLOWED) bypass via spoofed X-Forwarded-For / Client-IP headers

    phpSysInfo is a customizable PHP script that displays system information. Prior to 3.4.6, the PSI_ALLOWED access-control check in read_config.php trusts attacker-controlled X-Forwarded-For and Client-IP HTTP headers before REMOTE_ADDR. A remote unauthenticated attacker can supply an allowed address in one of these headers to impersonate a trusted client and access exposed hostname, kernel, CPU, memory, filesystem, and network-interface information. This issue is fixed in version 3.4.6.

    Publicación Actualización
  2. CVE-2006-3360

    Sin evaluarEPSS 5,57%Corrección disponible

    CVE-2006-3360

    Directory traversal vulnerability in index.php in phpSysInfo 2.5.1 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.

    • Actualiza a 3.2.5-3
    Publicación Actualización
  3. CVE-2005-3348

    Sin evaluarEPSS 1,98%Corrección disponible

    CVE-2005-3348

    HTTP response splitting vulnerability in index.php in phpSysInfo 2.4 and earlier, as used in phpgroupware 0.9.16 and earlier, and egroupware before 1.0.0.009, allows remote attackers to spoof web content and poison web caches via CRLF sequences in the charset parameter.

    • Actualiza a 2.3-7
    Publicación Actualización
  4. CVE-2005-3347

    Sin evaluarEPSS 3,55%Corrección disponible

    CVE-2005-3347

    Multiple directory traversal vulnerabilities in index.php in phpSysInfo 2.4 and earlier, as used in phpgroupware 0.9.16 and earlier, and egrouwpware before 1.0.0.009, allow remote attackers to include arbitrary files via .. (dot dot) sequences in the (1) sensor_program parameter or the (2) _SERVER[HTTP_ACCEPT_LANGUAGE] parameter, which overwrites an internal variable, a variant of CVE-2003-0536. NOTE: due to a typo in an advisory, an issue in osh was inadvertently linked to this identifier; the proper identifier for the osh issue is CVE-2005-3346.

    • Actualiza a 2.3-7
    Publicación Actualización
  5. CVE-2005-0870

    Sin evaluarEPSS 3,72%Código de explotación públicoCorrección disponible

    CVE-2005-0870

    Multiple cross-site scripting (XSS) vulnerabilities in phpSysInfo 2.3, when register_globals is enabled, allow remote attackers to inject arbitrary web script or HTML via the (1) sensor_program parameter to index.php, (2) text[language], (3) text[template], or (4) hide_picklist parameter to system_footer.php.

    • Actualiza a 2.3-7
    Publicación Actualización
  6. CVE-2005-0869

    Sin evaluarEPSS 5,18%Corrección disponible

    CVE-2005-0869

    phpSysInfo 2.3 allows remote attackers to obtain sensitive information via a direct request to (1) class.OpenBSD.inc.php, (2) class.NetBSD.inc.php, (3) class.FreeBSD.inc.php, (4) class.Darwin.inc.php, (5) XPath.class.php, (6) system_header.php, or (7) system_footer.php, which reveal the path in a PHP error message.

    • Actualiza a 2.3-3
    Publicación Actualización
  7. CVE-2003-0536

    Sin evaluarEPSS 1,47%Código de explotación públicoCorrección disponible

    CVE-2003-0536

    Directory traversal vulnerability in phpSysInfo 2.1 and earlier allows attackers with write access to a local directory to read arbitrary files as the PHP user or cause a denial of service via .. (dot dot) sequences in the (1) template or (2) lng parameters.

    • Actualiza a 2.1-1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →