p PatchFirst

CVE-2026-61448

CVE-2026-61448 · Parse Server 9.0.0 Stored XSS via malformed Content-Type

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Parse Server is affected by a stored cross-site scripting (XSS) vulnerability in versions >= 9.0.0, < 9.10.0-alpha.2 and <= 8.6.83. When an uploaded file's extension is not recognized by the mime package, Parse Server preserves the client-supplied Content-Type. A malformed Content-Type that is not a valid type/subtype media type (e.g., 'image', 'image/', or 'image//svg+xml') bypasses the fileUpload.fileExtensions blocklist and is stored unchanged. On storage adapters that persist and serve the uploaded Content-Type (such as Amazon S3, Google Cloud Storage, or Azure Blob Storage), a browser cannot parse the malformed value and falls back to MIME-sniffing; a file whose body begins with HTML is rendered as HTML, executing embedded script in the application's origin against other users who open the file URL. The default GridFS storage adapter is not affected. Fixed in 9.10.0-alpha.2 and 8.6.84.

CVSS 2.1 · Baja · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • parse-server

    Versiones
    • ≥ 9.0.0, < 9.10.0-alpha.2: Afectada (semver)
    • 9.10.0-alpha.2: No afectada (semver)

    Actualiza a 9.10.0-alpha.2

  • parse-server

    Versiones
    • ≥ 0, < 8.6.84: Afectada (semver)
    • 8.6.84: No afectada (semver)

    Actualiza a 8.6.84

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 9.0.0, < 9.10.0-alpha.2

    Actualiza a 9.10.0-alpha.2

  • parse-server npm

    Intervalos de versiones afectados
    • SEMVER: < 8.6.84

    Actualiza a 8.6.84

Fuentes originales

Comprueba tu servidor →