CVE-2026-61448
CVE-2026-61448 · Parse Server 9.0.0 Stored XSS via malformed Content-Type
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Parse Server is affected by a stored cross-site scripting (XSS) vulnerability in versions >= 9.0.0, < 9.10.0-alpha.2 and <= 8.6.83. When an uploaded file's extension is not recognized by the mime package, Parse Server preserves the client-supplied Content-Type. A malformed Content-Type that is not a valid type/subtype media type (e.g., 'image', 'image/', or 'image//svg+xml') bypasses the fileUpload.fileExtensions blocklist and is stored unchanged. On storage adapters that persist and serve the uploaded Content-Type (such as Amazon S3, Google Cloud Storage, or Azure Blob Storage), a browser cannot parse the malformed value and falls back to MIME-sniffing; a file whose body begins with HTML is rendered as HTML, executing embedded script in the application's origin against other users who open the file URL. The default GridFS storage adapter is not affected. Fixed in 9.10.0-alpha.2 and 8.6.84.
CVSS 2.1 · Faible · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
parse-server
- Versions du logiciel
- ≥ 9.0.0, < 9.10.0-alpha.2: Concernée (semver)
- 9.10.0-alpha.2: Non concernée (semver)
Mettez à jour vers 9.10.0-alpha.2
parse-server
- Versions du logiciel
- ≥ 0, < 8.6.84: Concernée (semver)
- 8.6.84: Non concernée (semver)
Mettez à jour vers 8.6.84
parse-server npm
- Plages de versions concernées
- SEMVER: ≥ 9.0.0, < 9.10.0-alpha.2
Mettez à jour vers 9.10.0-alpha.2
parse-server npm
- Plages de versions concernées
- SEMVER: < 8.6.84
Mettez à jour vers 8.6.84