p PatchFirst

CVE-2026-6270

CVE-2026-6270 · @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

@fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.

CVSS 9.1 · Crítica · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • @fastify/middie

    Versiones
    • ≥ 0, < 9.3.2: Afectada (semver)
    • 9.3.2: No afectada (semver)

    Actualiza a 9.3.2

  • @fastify/middie npm

    Intervalos de versiones afectados
    • SEMVER: < 9.3.2

    Actualiza a 9.3.2

Fuentes originales

Comprueba tu servidor →