p PatchFirst

CVE-2026-6270

CVE-2026-6270 · @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

@fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.

CVSS 9.1 · Kritisch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • @fastify/middie

    Softwareversionen
    • ≥ 0, < 9.3.2: Betroffen (semver)
    • 9.3.2: Nicht betroffen (semver)

    Auf 9.3.2 aktualisieren

  • @fastify/middie npm

    Betroffene Versionsbereiche
    • SEMVER: < 9.3.2

    Auf 9.3.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →