p PatchFirst

CVE-2026-6681

CVE-2026-6681 · PKCS#7 decode ignores caller output buffer size, writing past buffer bounds

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The PKCS#7 decode path ignores the caller-supplied output buffer size (outputSz), allowing decoded content to be written past the bounds of the provided buffer. This affects wolfSSL 5.9.0 and earlier and was fixed in the 5.9.1 release.

CVSS 1.0 · Baja · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • wolfssl

    Versiones
    • ≥ 3.10.0, ≤ 5.9.0: Afectada (semver)

    Sin corrección publicada

  • wolfssl Debian:12

    Versiones
    • 5.5.4-2
    • 5.5.4-2+deb12u1
    • 5.5.4-2+deb12u2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.5.4-2+deb12u3

    Actualiza a 5.5.4-2+deb12u3

  • wolfssl Debian:13

    Versiones
    • 5.7.2-0.1
    • 5.7.2-0.1+deb13u1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.7.2-0.1+deb13u2

    Actualiza a 5.7.2-0.1+deb13u2

  • wolfssl Ubuntu:16.04:LTS

    Versiones
    • 3.4.8+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • wolfssl Ubuntu:18.04:LTS

    Versiones
    • 3.10.2+dfsg-2
    • 3.12.0+dfsg-1
    • 3.12.2+dfsg-1
    • 3.13.0+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • wolfssl Ubuntu:20.04:LTS

    Versiones
    • 4.1.0+dfsg-2
    • 4.2.0+dfsg-1
    • 4.2.0+dfsg-2
    • 4.2.0+dfsg-3
    • 4.3.0+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • wolfssl Ubuntu:22.04:LTS

    Versiones
    • 4.6.0-3
    • 5.0.0-1
    • 5.1.1-1
    • 5.2.0-1
    • 5.2.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • wolfssl Ubuntu:24.04:LTS

    Versiones
    • 5.5.4-2
    • 5.5.4-2.1
    • 5.6.4-2
    • 5.6.6-1.2
    • 5.6.6-1.3
    • 5.6.6-1.3build1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • wolfssl Ubuntu:25.10

    Versiones
    • 5.7.2-0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →