p PatchFirst

CVE-2026-6681

CVE-2026-6681 · PKCS#7 decode ignores caller output buffer size, writing past buffer bounds

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

The PKCS#7 decode path ignores the caller-supplied output buffer size (outputSz), allowing decoded content to be written past the bounds of the provided buffer. This affects wolfSSL 5.9.0 and earlier and was fixed in the 5.9.1 release.

CVSS 1.0 · Niedrig · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • wolfssl

    Softwareversionen
    • ≥ 3.10.0, ≤ 5.9.0: Betroffen (semver)

    Keine Korrektur veröffentlicht

  • wolfssl Debian:12

    Softwareversionen
    • 5.5.4-2
    • 5.5.4-2+deb12u1
    • 5.5.4-2+deb12u2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.5.4-2+deb12u3

    Auf 5.5.4-2+deb12u3 aktualisieren

  • wolfssl Debian:13

    Softwareversionen
    • 5.7.2-0.1
    • 5.7.2-0.1+deb13u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.7.2-0.1+deb13u2

    Auf 5.7.2-0.1+deb13u2 aktualisieren

  • wolfssl Ubuntu:16.04:LTS

    Softwareversionen
    • 3.4.8+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wolfssl Ubuntu:18.04:LTS

    Softwareversionen
    • 3.10.2+dfsg-2
    • 3.12.0+dfsg-1
    • 3.12.2+dfsg-1
    • 3.13.0+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wolfssl Ubuntu:20.04:LTS

    Softwareversionen
    • 4.1.0+dfsg-2
    • 4.2.0+dfsg-1
    • 4.2.0+dfsg-2
    • 4.2.0+dfsg-3
    • 4.3.0+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wolfssl Ubuntu:22.04:LTS

    Softwareversionen
    • 4.6.0-3
    • 5.0.0-1
    • 5.1.1-1
    • 5.2.0-1
    • 5.2.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wolfssl Ubuntu:24.04:LTS

    Softwareversionen
    • 5.5.4-2
    • 5.5.4-2.1
    • 5.6.4-2
    • 5.6.6-1.2
    • 5.6.6-1.3
    • 5.6.6-1.3build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wolfssl Ubuntu:25.10

    Softwareversionen
    • 5.7.2-0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →