CVE-2026-69185
CVE-2026-69185 · Socket.IO: Zero-attachment Memory Exhaustion
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Socket.IO enables bidirectional and low-latency communication for every platform. Prior to 4.2.7, 3.4.5, and 3.3.6, a specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory. This vulnerability is fixed in 4.2.7, 3.4.5, and 3.3.6.
CVSS 7.5 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
socket.io
- Versiones
- < 3.3.6: Afectada
- >= 3.4.0, < 3.4.5: Afectada
- >= 4.0.0, < 4.2.7: Afectada
Sin corrección publicada
node-socket.io-parser Debian:12
- Versiones
- 4.2.1+~3.1.0-2
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Debian:13
- Versiones
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Debian:14
- Versiones
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.2.4+~3.1.2-1
Actualiza a 4.2.4+~3.1.2-1
socket.io-parser npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.0, < 4.2.7
Actualiza a 4.2.7
socket.io-parser npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.4.0, < 3.4.5
Actualiza a 3.4.5
socket.io-parser npm
- Intervalos de versiones afectados
- SEMVER: < 3.3.6
Actualiza a 3.3.6
node-socket.io-parser Ubuntu:18.04:LTS
- Versiones
- 2.3.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:20.04:LTS
- Versiones
- 3.3.0-1
- 3.4.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:22.04:LTS
- Versiones
- 4.0.2-1
- 4.1.1+~3.0.0-1
- 4.1.2+~3.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:24.04:LTS
- Versiones
- 4.2.1+~3.1.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:26.10
- Versiones
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-socket.io-parser Ubuntu:26.04:LTS
- Versiones
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/socketio/socket.io/security/advisories/GHSA-2m8v-j782-fhvr
- https://github.com/socketio/socket.io/commit/7c6ef571a00656718e9e05e3b948fd1758b2a7b4
- https://github.com/socketio/socket.io/commit/9c6323e5cde41bd75df3379b5fc9293664a5f240
- https://github.com/socketio/socket.io/commit/ced94ffa3ac020a8f3c14eb98a3bf34acb14d291
- https://nvd.nist.gov/vuln/detail/CVE-2026-69185