CVE-2026-69185
CVE-2026-69185 · Socket.IO: Zero-attachment Memory Exhaustion
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Socket.IO enables bidirectional and low-latency communication for every platform. Prior to 4.2.7, 3.4.5, and 3.3.6, a specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory. This vulnerability is fixed in 4.2.7, 3.4.5, and 3.3.6.
CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
socket.io
- Softwareversionen
- < 3.3.6: Betroffen
- >= 3.4.0, < 3.4.5: Betroffen
- >= 4.0.0, < 4.2.7: Betroffen
Keine Korrektur veröffentlicht
node-socket.io-parser Debian:12
- Softwareversionen
- 4.2.1+~3.1.0-2
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-socket.io-parser Debian:13
- Softwareversionen
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-socket.io-parser Debian:14
- Softwareversionen
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.2.4+~3.1.2-1
Auf 4.2.4+~3.1.2-1 aktualisieren
socket.io-parser npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.0.0, < 4.2.7
Auf 4.2.7 aktualisieren
socket.io-parser npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.4.0, < 3.4.5
Auf 3.4.5 aktualisieren
socket.io-parser npm
- Betroffene Versionsbereiche
- SEMVER: < 3.3.6
Auf 3.3.6 aktualisieren
node-socket.io-parser Ubuntu:18.04:LTS
- Softwareversionen
- 2.3.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-socket.io-parser Ubuntu:20.04:LTS
- Softwareversionen
- 3.3.0-1
- 3.4.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-socket.io-parser Ubuntu:22.04:LTS
- Softwareversionen
- 4.0.2-1
- 4.1.1+~3.0.0-1
- 4.1.2+~3.0.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-socket.io-parser Ubuntu:24.04:LTS
- Softwareversionen
- 4.2.1+~3.1.0-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-socket.io-parser Ubuntu:26.10
- Softwareversionen
- 4.2.1+~3.1.0-4
- 4.2.4+~3.1.2-1
- 4.2.4+~3.1.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-socket.io-parser Ubuntu:26.04:LTS
- Softwareversionen
- 4.2.1+~3.1.0-3
- 4.2.1+~3.1.0-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/socketio/socket.io/security/advisories/GHSA-2m8v-j782-fhvr
- https://github.com/socketio/socket.io/commit/7c6ef571a00656718e9e05e3b948fd1758b2a7b4
- https://github.com/socketio/socket.io/commit/9c6323e5cde41bd75df3379b5fc9293664a5f240
- https://github.com/socketio/socket.io/commit/ced94ffa3ac020a8f3c14eb98a3bf34acb14d291
- https://nvd.nist.gov/vuln/detail/CVE-2026-69185