CVE-2026-71430
CVE-2026-71430 · node-re2: String.prototype.replace(re2, template) aborts the Node process (uncatchable ToLocalChecked on empty MaybeLocal) when the result exceeds V8's max string length
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
node-re2 provides RE2 regular expression bindings for Node.js. Prior to version 1.25.1, the WrappedRE2::Replace function built its replacement result and passed it to V8 using ToLocalChecked without checking for the empty MaybeLocal that V8 returns when the resulting string or buffer exceeds V8's maximum string length. When a global replace uses an output amplifying replacement template, the result can grow quadratically with the input size, and once the result exceeds V8's maximum string length, the unchecked ToLocalChecked call causes a fatal, uncatchable process abort instead of a catchable exception. This issue is fixed in version 1.25.1.
CVSS 6.2 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
node-re2
- Versiones
- < 1.25.1: Afectada
Sin corrección publicada
node-re2 Debian:12
- Versiones
- 1.18.0+~cs2.13.8-1
- 1.19.2+~cs2.13.13-1
- 1.20.10+~cs2.13.13-1
- 1.20.12+~cs2.13.13-1
- 1.21.4+~cs2.13.13-1
- 1.21.4+~cs2.13.13-2
- 1.22.1+~cs1.3.5-1
- 1.23.3+~cs1.3.5-1
- 1.25.0+~cs1.6.0-1
- 1.25.0+~cs1.6.0-2
- 1.26.1+~cs1.7.0-1
- 1.26.1+~cs1.8.0-1
- 1.27.0+~cs1.8.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-re2 Debian:13
- Versiones
- 1.21.4+~cs2.13.13-2
- 1.22.1+~cs1.3.5-1
- 1.23.3+~cs1.3.5-1
- 1.25.0+~cs1.6.0-1
- 1.25.0+~cs1.6.0-2
- 1.26.1+~cs1.7.0-1
- 1.26.1+~cs1.8.0-1
- 1.27.0+~cs1.8.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-re2 Debian:14
- Versiones
- 1.21.4+~cs2.13.13-2
- 1.22.1+~cs1.3.5-1
- 1.23.3+~cs1.3.5-1
- 1.25.0+~cs1.6.0-1
- 1.25.0+~cs1.6.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.26.1+~cs1.7.0-1
Actualiza a 1.26.1+~cs1.7.0-1
re2 npm
- Intervalos de versiones afectados
- SEMVER: < 1.25.1
Actualiza a 1.25.1
node-re2 Ubuntu:20.04:LTS
- Versiones
- 1.10.4-1
- 1.10.5-1
- 1.10.5-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-re2 Ubuntu:22.04:LTS
- Versiones
- 1.15.9+~cs1.8.18-1
- 1.15.9+~cs1.8.18-2
- 1.16.0+~cs2.12.8-2
- 1.17.1+~cs2.12.8-1
- 1.17.2+~cs2.13.8-1
- 1.17.3+~cs2.13.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-re2 Ubuntu:24.04:LTS
- Versiones
- 1.18.0+~cs2.13.8-1build1
- 1.19.2+~cs2.13.13-1build1
- 1.20.10+~cs2.13.13-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-re2 Ubuntu:26.10
- Versiones
- 1.23.3+~cs1.3.5-1
- 1.25.0+~cs1.6.0-2
- 1.26.1+~cs1.7.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-re2 Ubuntu:26.04:LTS
- Versiones
- 1.22.1+~cs1.3.5-1
- 1.22.1+~cs1.3.5-1build2
- 1.22.1+~cs1.3.5-1build3
- 1.23.3+~cs1.3.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada