CVE-2026-71430
CVE-2026-71430 · node-re2: String.prototype.replace(re2, template) aborts the Node process (uncatchable ToLocalChecked on empty MaybeLocal) when the result exceeds V8's max string length
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
node-re2 provides RE2 regular expression bindings for Node.js. Prior to version 1.25.1, the WrappedRE2::Replace function built its replacement result and passed it to V8 using ToLocalChecked without checking for the empty MaybeLocal that V8 returns when the resulting string or buffer exceeds V8's maximum string length. When a global replace uses an output amplifying replacement template, the result can grow quadratically with the input size, and once the result exceeds V8's maximum string length, the unchecked ToLocalChecked call causes a fatal, uncatchable process abort instead of a catchable exception. This issue is fixed in version 1.25.1.
CVSS 6.2 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
node-re2
- Softwareversionen
- < 1.25.1: Betroffen
Keine Korrektur veröffentlicht
node-re2 Debian:12
- Softwareversionen
- 1.18.0+~cs2.13.8-1
- 1.19.2+~cs2.13.13-1
- 1.20.10+~cs2.13.13-1
- 1.20.12+~cs2.13.13-1
- 1.21.4+~cs2.13.13-1
- 1.21.4+~cs2.13.13-2
- 1.22.1+~cs1.3.5-1
- 1.23.3+~cs1.3.5-1
- 1.25.0+~cs1.6.0-1
- 1.25.0+~cs1.6.0-2
- 1.26.1+~cs1.7.0-1
- 1.26.1+~cs1.8.0-1
- 1.27.0+~cs1.8.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-re2 Debian:13
- Softwareversionen
- 1.21.4+~cs2.13.13-2
- 1.22.1+~cs1.3.5-1
- 1.23.3+~cs1.3.5-1
- 1.25.0+~cs1.6.0-1
- 1.25.0+~cs1.6.0-2
- 1.26.1+~cs1.7.0-1
- 1.26.1+~cs1.8.0-1
- 1.27.0+~cs1.8.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-re2 Debian:14
- Softwareversionen
- 1.21.4+~cs2.13.13-2
- 1.22.1+~cs1.3.5-1
- 1.23.3+~cs1.3.5-1
- 1.25.0+~cs1.6.0-1
- 1.25.0+~cs1.6.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.26.1+~cs1.7.0-1
Auf 1.26.1+~cs1.7.0-1 aktualisieren
re2 npm
- Betroffene Versionsbereiche
- SEMVER: < 1.25.1
Auf 1.25.1 aktualisieren
node-re2 Ubuntu:20.04:LTS
- Softwareversionen
- 1.10.4-1
- 1.10.5-1
- 1.10.5-1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-re2 Ubuntu:22.04:LTS
- Softwareversionen
- 1.15.9+~cs1.8.18-1
- 1.15.9+~cs1.8.18-2
- 1.16.0+~cs2.12.8-2
- 1.17.1+~cs2.12.8-1
- 1.17.2+~cs2.13.8-1
- 1.17.3+~cs2.13.8-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-re2 Ubuntu:24.04:LTS
- Softwareversionen
- 1.18.0+~cs2.13.8-1build1
- 1.19.2+~cs2.13.13-1build1
- 1.20.10+~cs2.13.13-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-re2 Ubuntu:26.10
- Softwareversionen
- 1.23.3+~cs1.3.5-1
- 1.25.0+~cs1.6.0-2
- 1.26.1+~cs1.7.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-re2 Ubuntu:26.04:LTS
- Softwareversionen
- 1.22.1+~cs1.3.5-1
- 1.22.1+~cs1.3.5-1build2
- 1.22.1+~cs1.3.5-1build3
- 1.23.3+~cs1.3.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht