p PatchFirst

CVE-2026-73299

CVE-2026-73299 · Prompty: Server-Side Template Injection to Remote Code Execution in the @prompty/core Nunjucks Renderer

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Prompty is a markdown file format (.prompty) for LLM prompts. Prior to 0.1.5 and 2.0.0-beta.5, the TypeScript Nunjucks renderer evaluated untrusted .prompty template bodies with unrestricted JavaScript member access. An attacker-controlled template could traverse constructor and prototype properties to execute JavaScript in the host Node.js process. This issue is fixed in versions 0.1.5 and 2.0.0-beta.5.

CVSS 10.0 · Crítica · EPSS 1,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • prompty

    Versiones
    • < 0.1.5: Afectada
    • >= 2.0.0-alpha.1, < 2.0.0-beta.5: Afectada

    Sin corrección publicada

  • @prompty/core npm

    Intervalos de versiones afectados
    • SEMVER: < 0.1.5

    Actualiza a 0.1.5

  • @prompty/core npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.0-alpha.1, < 2.0.0-beta.5

    Actualiza a 2.0.0-beta.5

Fuentes originales

Comprueba tu servidor →