p PatchFirst

CVE-2026-73299

CVE-2026-73299 · Prompty: Server-Side Template Injection to Remote Code Execution in the @prompty/core Nunjucks Renderer

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Prompty is a markdown file format (.prompty) for LLM prompts. Prior to 0.1.5 and 2.0.0-beta.5, the TypeScript Nunjucks renderer evaluated untrusted .prompty template bodies with unrestricted JavaScript member access. An attacker-controlled template could traverse constructor and prototype properties to execute JavaScript in the host Node.js process. This issue is fixed in versions 0.1.5 and 2.0.0-beta.5.

CVSS 10.0 · Critical · EPSS 1.8% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • prompty

    Versions
    • < 0.1.5: Affected
    • >= 2.0.0-alpha.1, < 2.0.0-beta.5: Affected

    No fix published

  • @prompty/core npm

    Affected ranges
    • SEMVER: < 0.1.5

    Update to 0.1.5

  • @prompty/core npm

    Affected ranges
    • SEMVER: ≥ 2.0.0-alpha.1, < 2.0.0-beta.5

    Update to 2.0.0-beta.5

Original sources

Check your server →