p PatchFirst

CVE-2026-76098

CVE-2026-76098 · Mistune has Denial of Service — RecursionError via Excessive Emphasis Markers in Markdown

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Mistune is a Python Markdown parser with renderers and plugins. Versions 3.3.0 through 3.3.2 are vulnerable to DoS through deeply nested tokens. HTML rendering creates deeply nested emphasis tokens from consecutive asterisk characters, and recursive rendering in HTMLRenderer.render_token() can exceed Python's recursion limit and raise RecursionError, allowing crafted Markdown to crash a parsing process. This issue is fixed in version 3.3.3

CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • mistune

    Versiones
    • >= 3.3.0, < 3.3.3: Afectada

    Sin corrección publicada

  • mistune Debian:12

    Versiones
    • 2.0.4-1
    • 2.0.4-2
    • 3.0.2-1
    • 3.0.2-2
    • 3.1.3-1
    • 3.1.4-1
    • 3.3.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune Debian:13

    Versiones
    • 3.1.3-1
    • 3.1.4-1
    • 3.3.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune Debian:14

    Versiones
    • 3.1.3-1
    • 3.1.4-1
    • 3.3.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune PyPI

    Versiones
    • 3.3.0
    • 3.3.1
    • 3.3.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 3.3.0, < 3.3.3

    Actualiza a 3.3.3

  • mistune Ubuntu:16.04:LTS

    Versiones
    • 0.6-2
    • 0.7.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune Ubuntu:18.04:LTS

    Versiones
    • 0.7.4-1
    • 0.8-1
    • 0.8.1-1
    • 0.8.3-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune Ubuntu:20.04:LTS

    Versiones
    • 0.8.4-1
    • 0.8.4-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune Ubuntu:22.04:LTS

    Versiones
    • 0.8.4-4
    • 0.8.4-5
    • 2.0.0-1+really0.8.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune Ubuntu:24.04:LTS

    Versiones
    • 2.0.4-2
    • 3.0.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune Ubuntu:26.10

    Versiones
    • 3.1.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mistune Ubuntu:26.04:LTS

    Versiones
    • 3.1.3-1
    • 3.1.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →