CVE-2026-76098
CVE-2026-76098 · Mistune has Denial of Service — RecursionError via Excessive Emphasis Markers in Markdown
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Mistune is a Python Markdown parser with renderers and plugins. Versions 3.3.0 through 3.3.2 are vulnerable to DoS through deeply nested tokens. HTML rendering creates deeply nested emphasis tokens from consecutive asterisk characters, and recursive rendering in HTMLRenderer.render_token() can exceed Python's recursion limit and raise RecursionError, allowing crafted Markdown to crash a parsing process. This issue is fixed in version 3.3.3
CVSS 7.5 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
mistune
- Softwareversionen
- >= 3.3.0, < 3.3.3: Betroffen
Keine Korrektur veröffentlicht
mistune Debian:12
- Softwareversionen
- 2.0.4-1
- 2.0.4-2
- 3.0.2-1
- 3.0.2-2
- 3.1.3-1
- 3.1.4-1
- 3.3.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune Debian:13
- Softwareversionen
- 3.1.3-1
- 3.1.4-1
- 3.3.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune Debian:14
- Softwareversionen
- 3.1.3-1
- 3.1.4-1
- 3.3.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune PyPI
- Softwareversionen
- 3.3.0
- 3.3.1
- 3.3.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.3.0, < 3.3.3
Auf 3.3.3 aktualisieren
mistune Ubuntu:16.04:LTS
- Softwareversionen
- 0.6-2
- 0.7.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune Ubuntu:18.04:LTS
- Softwareversionen
- 0.7.4-1
- 0.8-1
- 0.8.1-1
- 0.8.3-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune Ubuntu:20.04:LTS
- Softwareversionen
- 0.8.4-1
- 0.8.4-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune Ubuntu:22.04:LTS
- Softwareversionen
- 0.8.4-4
- 0.8.4-5
- 2.0.0-1+really0.8.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune Ubuntu:24.04:LTS
- Softwareversionen
- 2.0.4-2
- 3.0.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune Ubuntu:26.10
- Softwareversionen
- 3.1.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mistune Ubuntu:26.04:LTS
- Softwareversionen
- 3.1.3-1
- 3.1.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht