p PatchFirst

CVE-2026-84375

CVE-2026-84375 · js-yaml: maxTotalMergeKeys does not limit CPU use for empty merge sources

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

js-yaml is a JavaScript YAML parser and dumper. From 3.0.0 until 3.15.2, 4.3.2, and 5.4.1, maxTotalMergeKeys in lib/js-yaml/loader.js and lib/loader.js does not count empty mapping sources while processing the merge key <<. An attacker can alias a large sequence of empty mappings into many merge targets, causing O(N * K) processing while totalMergeKeys remains unchanged and the configured resource limit is never reached. A relatively small YAML document can therefore cause prolonged CPU consumption in applications that parse untrusted YAML, and merge processing is enabled by default on these release lines. In v3 & v4, merge is enabled by default so the severity score is higher. This issue is fixed in versions 3.15.2, 4.3.2, and 5.4.1.

CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • js-yaml

    Versiones
    • >= 3.0.0, < 3.15.2: Afectada
    • >= 4.0.0, < 4.3.2: Afectada
    • >= 5.0.0, < 5.4.1: Afectada

    Sin corrección publicada

  • node-js-yaml Debian:12

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    • 4.3.2+~4.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Debian:13

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    • 4.3.2+~4.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Debian:14

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.3.2+~4.0.9-1

    Actualiza a 4.3.2+~4.0.9-1

  • js-yaml npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.3.2

    Actualiza a 4.3.2

  • js-yaml npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.15.2

    Actualiza a 3.15.2

  • node-js-yaml Ubuntu:18.04:LTS

    Versiones
    • 3.9.1+dfsg-1
    • 3.10.0+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:20.04:LTS

    Versiones
    • 3.13.1+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:22.04:LTS

    Versiones
    • 3.14.1+dfsg+~3.12.6-2
    • 4.1.0+dfsg+~4.0.5-4ubuntu1
    • 4.1.0+dfsg+~4.0.5-5
    • 4.1.0+dfsg+~4.0.5-6
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:24.04:LTS

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:26.10

    Versiones
    • 4.1.1+dfsg+~4.0.9-1
    • 4.2.0+~4.0.9-1
    • 4.2.0+~4.0.9-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-js-yaml Ubuntu:26.04:LTS

    Versiones
    • 4.1.0+dfsg+~4.0.5-7
    • 4.1.1+dfsg+~4.0.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →