CVE-2026-84375
CVE-2026-84375 · js-yaml: maxTotalMergeKeys does not limit CPU use for empty merge sources
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
js-yaml is a JavaScript YAML parser and dumper. From 3.0.0 until 3.15.2, 4.3.2, and 5.4.1, maxTotalMergeKeys in lib/js-yaml/loader.js and lib/loader.js does not count empty mapping sources while processing the merge key <<. An attacker can alias a large sequence of empty mappings into many merge targets, causing O(N * K) processing while totalMergeKeys remains unchanged and the configured resource limit is never reached. A relatively small YAML document can therefore cause prolonged CPU consumption in applications that parse untrusted YAML, and merge processing is enabled by default on these release lines. In v3 & v4, merge is enabled by default so the severity score is higher. This issue is fixed in versions 3.15.2, 4.3.2, and 5.4.1.
CVSS 7.5 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
js-yaml
- Softwareversionen
- >= 3.0.0, < 3.15.2: Betroffen
- >= 4.0.0, < 4.3.2: Betroffen
- >= 5.0.0, < 5.4.1: Betroffen
Keine Korrektur veröffentlicht
node-js-yaml Debian:12
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Debian:13
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- 4.3.2+~4.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Debian:14
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.3.2+~4.0.9-1
Auf 4.3.2+~4.0.9-1 aktualisieren
js-yaml npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.0.0, < 4.3.2
Auf 4.3.2 aktualisieren
js-yaml npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.15.2
Auf 3.15.2 aktualisieren
node-js-yaml Ubuntu:18.04:LTS
- Softwareversionen
- 3.9.1+dfsg-1
- 3.10.0+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:20.04:LTS
- Softwareversionen
- 3.13.1+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:22.04:LTS
- Softwareversionen
- 3.14.1+dfsg+~3.12.6-2
- 4.1.0+dfsg+~4.0.5-4ubuntu1
- 4.1.0+dfsg+~4.0.5-5
- 4.1.0+dfsg+~4.0.5-6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:24.04:LTS
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:26.10
- Softwareversionen
- 4.1.1+dfsg+~4.0.9-1
- 4.2.0+~4.0.9-1
- 4.2.0+~4.0.9-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-js-yaml Ubuntu:26.04:LTS
- Softwareversionen
- 4.1.0+dfsg+~4.0.5-7
- 4.1.1+dfsg+~4.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/nodeca/js-yaml/security/advisories/GHSA-2883-xcg3-v3hh
- https://github.com/nodeca/js-yaml/pull/797
- https://github.com/nodeca/js-yaml/commit/3485bc06ff8a0251505f44a00414d90df2466639
- https://github.com/nodeca/js-yaml/commit/6a8e05f9a485188ed730ac81e81ae221352ef480
- https://github.com/nodeca/js-yaml/commit/d90b6612a5a84385bdcb556c44578eac76dc0f6b
- https://github.com/nodeca/js-yaml/releases/tag/3.15.2
- https://github.com/nodeca/js-yaml/releases/tag/4.3.2
- https://github.com/nodeca/js-yaml/releases/tag/5.4.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-84375