p PatchFirst

CVE-2026-87859

CVE-2026-87859 · morgan vulnerable to Log Injection via unescaped double quote in quoted log fields

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

morgan is an HTTP request logger middleware for Node.js. In versions before 1.12.1, its escapeLogField() function does not escape the double quote character, which delimits the quoted fields of the Apache combined log format that morgan emits. An unauthenticated remote attacker who controls a value written to a quoted field, such as the User-Agent or Referer header, can include a double quote to close that field early, so a log consumer that parses the log by field position reads attacker-supplied text as the following field. In the built-in formats this makes the recorded value differ from the value that was sent, and in custom formats that quote an attacker-controlled token before a server-controlled one it can forge values such as the response status. No newline is injected, so record separation stays intact. The issue is fixed in morgan 1.12.1, which escapes the double quote. Users should upgrade to morgan 1.12.1 or later.

CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • morgan

    Versiones
    • ≥ 0, < 1.12.1: Afectada (semver)
    • 1.12.1: No afectada (semver)

    Actualiza a 1.12.1

  • node-morgan Debian:12

    Versiones
    • 1.10.0+~1.9.3-1
    • 1.10.1+~1.9.10-1
    • 1.12.0+~1.9.10-1
    • 1.12.1+~1.9.10-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-morgan Debian:13

    Versiones
    • 1.10.0+~1.9.3-1
    • 1.10.1+~1.9.10-1
    • 1.12.0+~1.9.10-1
    • 1.12.1+~1.9.10-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-morgan Debian:14

    Versiones
    • 1.10.0+~1.9.3-1
    • 1.10.1+~1.9.10-1
    • 1.12.0+~1.9.10-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.12.1+~1.9.10-1

    Actualiza a 1.12.1+~1.9.10-1

  • morgan npm

    Intervalos de versiones afectados
    • SEMVER: < 1.12.1

    Actualiza a 1.12.1

  • node-morgan Ubuntu:22.04:LTS

    Versiones
    • 1.10.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-morgan Ubuntu:24.04:LTS

    Versiones
    • 1.10.0+~1.9.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-morgan Ubuntu:26.10

    Versiones
    • 1.10.1+~1.9.10-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-morgan Ubuntu:26.04:LTS

    Versiones
    • 1.10.0+~1.9.3-1
    • 1.10.1+~1.9.10-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →