CVE-2026-87859
CVE-2026-87859 · morgan vulnerable to Log Injection via unescaped double quote in quoted log fields
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
morgan is an HTTP request logger middleware for Node.js. In versions before 1.12.1, its escapeLogField() function does not escape the double quote character, which delimits the quoted fields of the Apache combined log format that morgan emits. An unauthenticated remote attacker who controls a value written to a quoted field, such as the User-Agent or Referer header, can include a double quote to close that field early, so a log consumer that parses the log by field position reads attacker-supplied text as the following field. In the built-in formats this makes the recorded value differ from the value that was sent, and in custom formats that quote an attacker-controlled token before a server-controlled one it can forge values such as the response status. No newline is injected, so record separation stays intact. The issue is fixed in morgan 1.12.1, which escapes the double quote. Users should upgrade to morgan 1.12.1 or later.
CVSS 5.3 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
morgan
- Softwareversionen
- ≥ 0, < 1.12.1: Betroffen (semver)
- 1.12.1: Nicht betroffen (semver)
Auf 1.12.1 aktualisieren
node-morgan Debian:12
- Softwareversionen
- 1.10.0+~1.9.3-1
- 1.10.1+~1.9.10-1
- 1.12.0+~1.9.10-1
- 1.12.1+~1.9.10-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-morgan Debian:13
- Softwareversionen
- 1.10.0+~1.9.3-1
- 1.10.1+~1.9.10-1
- 1.12.0+~1.9.10-1
- 1.12.1+~1.9.10-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-morgan Debian:14
- Softwareversionen
- 1.10.0+~1.9.3-1
- 1.10.1+~1.9.10-1
- 1.12.0+~1.9.10-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.12.1+~1.9.10-1
Auf 1.12.1+~1.9.10-1 aktualisieren
morgan npm
- Betroffene Versionsbereiche
- SEMVER: < 1.12.1
Auf 1.12.1 aktualisieren
node-morgan Ubuntu:22.04:LTS
- Softwareversionen
- 1.10.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-morgan Ubuntu:24.04:LTS
- Softwareversionen
- 1.10.0+~1.9.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-morgan Ubuntu:26.10
- Softwareversionen
- 1.10.1+~1.9.10-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-morgan Ubuntu:26.04:LTS
- Softwareversionen
- 1.10.0+~1.9.3-1
- 1.10.1+~1.9.10-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht