p PatchFirst

CVE-2026-92940

CVE-2026-92940 · vm2 3.11.3 through 3.11.6 HTTPS Credential Exposure via globalAgent

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to sandboxed code when a NodeVM is explicitly configured to allow require('https'). The builtin loader wraps host modules in a read-only proxy, but method calls such as Agent.prototype.on() are forwarded to the underlying host object, so sandbox code can register a listener for the agent's 'free' event. When an unrelated host HTTPS request releases a pooled connection, the listener receives the live host request options and the host TLSSocket, allowing sandboxed code to read the host's Authorization header and private destination host/port, attach a data listener to the released socket and read subsequent host response bodies in plaintext, and issue attacker-chosen authenticated requests using the stolen credentials. The issue is fixed in 3.11.7.

CVSS 10.0 · Crítica · EPSS 0,5% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • vm2

    Versiones
    • ≥ 3.11.3, < 3.11.7: Afectada (semver)
    • 3.11.7: No afectada (semver)

    Actualiza a 3.11.7

  • vm2 npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.11.3, < 3.11.7

    Actualiza a 3.11.7

Fuentes originales

Comprueba tu servidor →