p PatchFirst

CVE-2026-92940

CVE-2026-92940 · vm2 3.11.3 through 3.11.6 HTTPS Credential Exposure via globalAgent

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to sandboxed code when a NodeVM is explicitly configured to allow require('https'). The builtin loader wraps host modules in a read-only proxy, but method calls such as Agent.prototype.on() are forwarded to the underlying host object, so sandbox code can register a listener for the agent's 'free' event. When an unrelated host HTTPS request releases a pooled connection, the listener receives the live host request options and the host TLSSocket, allowing sandboxed code to read the host's Authorization header and private destination host/port, attach a data listener to the released socket and read subsequent host response bodies in plaintext, and issue attacker-chosen authenticated requests using the stolen credentials. The issue is fixed in 3.11.7.

CVSS 10.0 · Critique · EPSS 0,5% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • vm2

    Versions du logiciel
    • ≥ 3.11.3, < 3.11.7: Concernée (semver)
    • 3.11.7: Non concernée (semver)

    Mettez à jour vers 3.11.7

  • vm2 npm

    Plages de versions concernées
    • SEMVER: ≥ 3.11.3, < 3.11.7

    Mettez à jour vers 3.11.7

Sources originales

Vérifiez votre serveur →