p PatchFirst

CVE-2026-97711

CVE-2026-97711 · Serialize JavaScript: Cross-site scripting (XSS) via unescaped </script> in serialized function bodies

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Serialize JavaScript serializes JavaScript values to a superset of JSON that includes regular expressions and functions. From 7.1.1 until 7.1.2, function values serialized by serialize-javascript are not fully protected against script-closing tags in attacker-influenced function source because SCRIPT_CLOSE_REGEXP can consume a second closing tag inside one match. When the serialized function is embedded in a script element, the surviving closing tag terminates the element early and causes the remaining output to be parsed as HTML, enabling cross-site scripting in the page origin. Only function values are affected; ordinary data values and options.isJSON output are unaffected. This issue is fixed in version 7.1.2.

CVSS 2.3 · Baja · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • serialize-javascript

    Versiones
    • >= 7.1.1, < 7.1.2: Afectada

    Sin corrección publicada

  • node-serialize-javascript Debian:12

    Versiones
    • 6.0.0-2
    • 6.0.0-2+deb12u1
    • 6.0.1-1
    • 6.0.2-1
    • 7.0.4+~5.0.4-1
    • 7.0.5+~5.0.4-1
    • 7.0.7+~5.0.4-1
    • 7.1.2+~5.0.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-serialize-javascript Debian:13

    Versiones
    • 6.0.2-1
    • 7.0.4+~5.0.4-1
    • 7.0.5+~5.0.4-1
    • 7.0.7+~5.0.4-1
    • 7.1.2+~5.0.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-serialize-javascript Debian:14

    Versiones
    • 6.0.2-1
    • 7.0.4+~5.0.4-1
    • 7.0.5+~5.0.4-1
    • 7.0.7+~5.0.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.1.2+~5.0.4-1

    Actualiza a 7.1.2+~5.0.4-1

  • serialize-javascript npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 7.1.1, < 7.1.2

    Actualiza a 7.1.2

  • node-serialize-javascript Ubuntu:22.04:LTS

    Versiones
    • 5.0.1-2
    • 6.0.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-serialize-javascript Ubuntu:24.04:LTS

    Versiones
    • 6.0.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-serialize-javascript Ubuntu:26.10

    Versiones
    • 7.0.4+~5.0.4-1
    • 7.0.5+~5.0.4-1
    • 7.0.7+~5.0.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-serialize-javascript Ubuntu:26.04:LTS

    Versiones
    • 6.0.2-1
    • 7.0.4+~5.0.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →