CVE-2026-97711
CVE-2026-97711 · Serialize JavaScript: Cross-site scripting (XSS) via unescaped </script> in serialized function bodies
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Serialize JavaScript serializes JavaScript values to a superset of JSON that includes regular expressions and functions. From 7.1.1 until 7.1.2, function values serialized by serialize-javascript are not fully protected against script-closing tags in attacker-influenced function source because SCRIPT_CLOSE_REGEXP can consume a second closing tag inside one match. When the serialized function is embedded in a script element, the surviving closing tag terminates the element early and causes the remaining output to be parsed as HTML, enabling cross-site scripting in the page origin. Only function values are affected; ordinary data values and options.isJSON output are unaffected. This issue is fixed in version 7.1.2.
CVSS 2.3 · Niedrig · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
serialize-javascript
- Softwareversionen
- >= 7.1.1, < 7.1.2: Betroffen
Keine Korrektur veröffentlicht
node-serialize-javascript Debian:12
- Softwareversionen
- 6.0.0-2
- 6.0.0-2+deb12u1
- 6.0.1-1
- 6.0.2-1
- 7.0.4+~5.0.4-1
- 7.0.5+~5.0.4-1
- 7.0.7+~5.0.4-1
- 7.1.2+~5.0.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-serialize-javascript Debian:13
- Softwareversionen
- 6.0.2-1
- 7.0.4+~5.0.4-1
- 7.0.5+~5.0.4-1
- 7.0.7+~5.0.4-1
- 7.1.2+~5.0.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-serialize-javascript Debian:14
- Softwareversionen
- 6.0.2-1
- 7.0.4+~5.0.4-1
- 7.0.5+~5.0.4-1
- 7.0.7+~5.0.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.1.2+~5.0.4-1
Auf 7.1.2+~5.0.4-1 aktualisieren
serialize-javascript npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 7.1.1, < 7.1.2
Auf 7.1.2 aktualisieren
node-serialize-javascript Ubuntu:22.04:LTS
- Softwareversionen
- 5.0.1-2
- 6.0.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-serialize-javascript Ubuntu:24.04:LTS
- Softwareversionen
- 6.0.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-serialize-javascript Ubuntu:26.10
- Softwareversionen
- 7.0.4+~5.0.4-1
- 7.0.5+~5.0.4-1
- 7.0.7+~5.0.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-serialize-javascript Ubuntu:26.04:LTS
- Softwareversionen
- 6.0.2-1
- 7.0.4+~5.0.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht