p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de thrift · Página 4

Vulnerabilidades publicadas para thrift en los últimos 30 días: 61. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 91

  1. CVE-2026-94635

    Alta · CVSS 8.7EPSS 0,34%Sin corrección publicada

    Apache Thrift: Lua `TBinaryProtocol:readMessageBegin` bypasses `checkStringSize` on the pre-versioned name

    Allocation of resources without limits or throttling, Improper handling of length parameter inconsistency vulnerability in Apache Thrift Lua bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

    Publicación Actualización
  2. CVE-2026-66053

    Media · CVSS 5.9EPSS 0,29%Sin corrección publicada

    Apache Thrift: Python TSSLSocket Hostname Matcher Import

    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603

    Publicación Actualización
  3. CVE-2026-58662

    Alta · CVSS 8.7EPSS 1,08%Sin corrección publicada

    Apache Thrift: C++ THeaderTransport::readString() info-header length bounds bypass

    Improper Validation of Specified Quantity in Input, Out-of-bounds Read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  4. CVE-2026-58389

    Alta · CVSS 8.7EPSS 1,03%Sin corrección publicada

    Apache Thrift: Rust binary protocol non-strict path missing string size limit

    Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Rust bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  5. CVE-2026-55971

    Crítica · CVSS 9.3EPSS 0,98%Sin corrección publicada

    Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform()

    Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  6. CVE-2026-55969

    Alta · CVSS 8.7EPSS 1,03%Sin corrección publicada

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: integer overflow in TProtocol::checkReadBytesAvailable()

    Integer Overflow or Wraparound vulnerability in Apache Thrift C++, c_glib, Go, netstd, Delphi and Haxe bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  7. CVE-2026-55968

    Alta · CVSS 8.7EPSS 1,03%Sin corrección publicada

    Apache Thrift: Node.js quadratic-time DoS in server receive transports

    Inefficient Algorithmic Complexity, Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Node.js bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  8. CVE-2026-49158

    Alta · CVSS 7.5EPSS 1,03%Sin corrección publicada

    Apache Thrift: Ruby THeaderTransport ZLIB Decompression Bomb

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  9. CVE-2026-48586

    Alta · CVSS 8.7EPSS 1,03%Sin corrección publicada

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TZlibTransport Decompression Size Limit

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift C++, Java, Python, Go, D, C/GLib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  10. CVE-2026-48145

    Alta · CVSS 8.2EPSS 0,42%Sin corrección publicada

    Apache Thrift: C++ TSSLSocket matchName() RFC 6125 Wildcard Bypass

    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  11. CVE-2026-48144

    Crítica · CVSS 9.1EPSS 0,4%Sin corrección publicada

    Apache Thrift: c_glib TLS Client Missing Hostname Verification

    Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift c_glib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  12. CVE-2026-45112

    Media · CVSS 6.9EPSS 1,03%Sin corrección publicada

    Apache Thrift: Unbounded Read Leading to Denial of Service

    Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Java bindings. This issue affects Apache Thrift: from 0.19.0 before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  13. CVE-2026-43871

    Alta · CVSS 8.7EPSS 1,03%Sin corrección publicada

    Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit

    Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Thrift Python, Go, PHP and Java bindings.This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  14. CVE-2026-41608

    Alta · CVSS 7.5EPSS 1,03%Sin corrección publicada

    Apache Thrift: Unbounded Zlib Decompression in Python THeaderTransport

    Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

    Publicación Actualización
  15. CVE-2026-43870

    Alta · CVSS 7.3EPSS 0,38%Sin corrección publicada

    Apache Thrift: Node.js web_server.js multi-vulnerability

    Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →