p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de rustc · Página 2

Vulnerabilidades publicadas para rustc en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 24

  1. CVE-2019-1010299

    Media · CVSS 5.3EPSS 1,52%Corrección disponible

    CVE-2019-1010299

    The Rust Programming Language Standard Library 1.18.0 and later is affected by: CWE-200: Information Exposure. The impact is: Contents of uninitialized memory could be printed to string or to log file. The component is: Debug trait implementation for std::collections::vec_deque::Iter. The attack vector is: The program needs to invoke debug printing for iterator over an empty VecDeque. The fixed version is: 1.30.0, nightly versions after commit b85e4cc8fadaabd41da5b9645c08c68b8f89908d.

    • Actualiza a 1.30.0+dfsg1-1
    Publicación Actualización
  2. CVE-2018-1000810

    Crítica · CVSS 9.8EPSS 2,99%Corrección disponible

    CVE-2018-1000810

    The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.

    • Actualiza a 1.30.0+dfsg1-1
    Publicación Actualización
  3. CVE-2018-1000657

    Alta · CVSS 7.8EPSS 0,54%Corrección disponible

    CVE-2018-1000657

    Rust Programming Language Rust standard library version Commit bfa0e1f58acf1c28d500c34ed258f09ae021893e and later; stable release 1.3.0 and later contains a Buffer Overflow vulnerability in std::collections::vec_deque::VecDeque::reserve() function that can result in Arbitrary code execution, but no proof-of-concept exploit is currently published.. This vulnerability appears to have been fixed in after commit fdfafb510b1a38f727e920dccbeeb638d39a8e60; stable release 1.22.0 and later.

    • Actualiza a 1.22.1+dfsg1-1
    Publicación Actualización
  4. CVE-2018-1000622

    Alta · CVSS 7.8EPSS 1,82%Corrección disponible

    CVE-2018-1000622

    The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.

    • Actualiza a 1.27.1+dfsg1-1~exp1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →