CVE-2018-1000622
CVE-2018-1000622
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.
CVSS 7.8 · Alta · EPSS 1,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
rustc Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Actualiza a 1.27.1+dfsg1-1~exp1
rustc Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Actualiza a 1.27.1+dfsg1-1~exp1
rustc Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.27.1+dfsg1-1~exp1
Actualiza a 1.27.1+dfsg1-1~exp1
Fuentes originales
- https://security.gentoo.org/glsa/201812-11
- https://groups.google.com/forum/#%21topic/rustlang-security-announcements/4ybxYLTtXuM
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00031.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000622