p PatchFirst

CVE-2018-1000810

CVE-2018-1000810

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.

CVSS 9.8 · Crítica · EPSS 3,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • rustc Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Actualiza a 1.30.0+dfsg1-1

  • rustc Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Actualiza a 1.30.0+dfsg1-1

  • rustc Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Actualiza a 1.30.0+dfsg1-1

Fuentes originales

Comprueba tu servidor →