p PatchFirst

GHSA-7fjv-25q9-2w88

GHSA-7fjv-25q9-2w88 · State Guessing Vulnerability in laravel/socialite

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

laravel/socialite versions prior to 2.0.10 are susceptible to a security vulnerability related to state guessing during OAuth authentication. This vulnerability could potentially lead to session hijacking, allowing attackers to compromise user sessions. The issue has been addressed and fixed in version 2.0.10.

Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • laravel/socialite Packagist

    Versiones
    • v1.0.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v2.0.0
    • v2.0.1
    • v2.0.2
    • v2.0.3
    • v2.0.4
    • v2.0.5
    • v2.0.6
    • v2.0.7
    • v2.0.8
    • v2.0.9
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.0.0, < 2.0.10

    Actualiza a 2.0.10

Fuentes originales

Comprueba tu servidor →