GHSA-7hh9-gp72-wh7h
GHSA-7hh9-gp72-wh7h · Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Users are affected if they meet the following preconditions: - Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0, - Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0/laravel-auth0 to version 7.20.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
CVSS 6.8 · Media · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
auth0/login Packagist
- Versiones
- 7.0.0
- 7.0.1
- 7.1.0
- 7.10.0
- 7.10.1
- 7.11.0
- 7.12.0
- 7.13.0
- 7.14.0
- 7.15.0
- 7.16.0
- 7.17.0
- 7.18.0
- 7.19.0
- 7.2.0
- 7.2.1
- 7.2.2
- 7.3.0
- 7.4.0
- 7.5.0
- 7.5.1
- 7.5.2
- 7.6.0
- 7.7.0
- 7.8.0
- 7.8.1
- 7.9.0
- 7.9.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 7.0.0, < 7.20.0
Actualiza a 7.20.0
Fuentes originales
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-7hh9-gp72-wh7h
- https://github.com/auth0/laravel-auth0/commit/a1c3344dc0e5a36e8f56c8cfc535728d3d7558f3
- https://github.com/auth0/laravel-auth0
- https://github.com/auth0/laravel-auth0/releases/tag/7.20.0
- https://osv.dev/vulnerability/GHSA-7hh9-gp72-wh7h