p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de auth0/login

Vulnerabilidades publicadas para auth0/login en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 5

  1. GHSA-fmg6-246m-9g2v

    Alta · CVSS 8.2Corrección disponible

    Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption

    ### Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. ### Am I Affected? You are affected if you meet the following preconditions: - Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0 - Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. ### Resolution Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.

    • Actualiza a 7.21.0
    Publicación Actualización
  2. GHSA-7hh9-gp72-wh7h

    Media · CVSS 6.8Corrección disponible

    Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency

    ### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Users are affected if they meet the following preconditions: - Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0, - Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0/laravel-auth0 to version 7.20.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery

    • Actualiza a 7.20.0
    Publicación Actualización
  3. GHSA-hjfh-5jmm-xr24

    Baja · CVSS 3.3Corrección disponible

    laravel-auth0 SDK Does Not Properly Handle File Types in Bulk User Import

    ### Overview In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. ### Am I affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 laravel-auth0 SDK with version between 4.0.0 and 7.18.0, 2. Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0. ### Fix Upgrade Auth0 laravel-auth0 SDK to version 7.19.0 or greater. ### Acknowledgement Okta would like to thank Mohamed Amine Saidani (pw

    • Actualiza a 7.19.0
    Publicación Actualización
  4. GHSA-c42h-56wx-h85q

    Crítica · CVSS 9.3Corrección disponible

    laravel-auth0 SDK Deserialization of Untrusted Data vulnerability

    **Overview** The laravel-auth0 SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. **Am I Affected?** You are affected by this vulnerability if you meet the following preconditions: 1. Applications using laravel-auth0 SDK, versions between 7.0.0-BETA1 to 7.2.1. 2. Laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0. **Fix** Upgrade Auth0/laravel-auth0 to the latest version (v7.17.0). **Acknowledgement** Okta would l

    • Actualiza a 7.2.2
    Publicación Actualización
  5. GHSA-9fwj-9mjf-rhj3

    Crítica · CVSS 9.1Corrección disponible

    laravel-auth0 SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions

    **Overview** Session cookies of applications using the laravel-auth0 SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. **Am I Affected?** You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using laravel-auth0 SDK with version <=7.16.0 2. laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. 3. Session storage configured with CookieStore. **Fix** Upgrade Auth0/laravel-auth0 to v7.17.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note th

    • Actualiza a 7.17.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →