GHSA-vvg7-8rmq-92g7
GHSA-vvg7-8rmq-92g7 · Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Projects are affected if they meet the following preconditions: - Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.4.0, - Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0 Wordpress plugin to version 5.5.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
CVSS 6.8 · Media · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
auth0/wordpress Packagist
- Versiones
- 5.0.0
- 5.0.0-BETA0
- 5.0.0-BETA1
- 5.0.1
- 5.1.0
- 5.2.0
- 5.2.1
- 5.3.0
- 5.4.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 5.0.0-BETA0, < 5.5.0
Actualiza a 5.5.0