p PatchFirst

GHSA-vvg7-8rmq-92g7

GHSA-vvg7-8rmq-92g7 · Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency

This page contains facts from public vulnerability sources. Check the original advisory before updating.

### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Projects are affected if they meet the following preconditions: - Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.4.0, - Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0 Wordpress plugin to version 5.5.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.

CVSS 6.8 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • auth0/wordpress Packagist

    Versions
    • 5.0.0
    • 5.0.0-BETA0
    • 5.0.0-BETA1
    • 5.0.1
    • 5.1.0
    • 5.2.0
    • 5.2.1
    • 5.3.0
    • 5.4.0
    Affected ranges
    • ECOSYSTEM: ≥ 5.0.0-BETA0, < 5.5.0

    Update to 5.5.0

Original sources

Check your server →