p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de @grpc/grpc-js

Vulnerabilidades publicadas para @grpc/grpc-js en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 6

  1. CVE-2026-101916

    Alta · CVSS 7.4EPSS 0,21%Corrección disponible

    @grpc/grpc-js: In certain configurations, getAuthContext can return unauthorized certificates as though they were authorized

    @grpc/grpc-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.13.6 and 1.14.5, getAuthContext does not distinguish authorized from unauthorized peer certificates when server credentials set requireClientCertificate to false. When applications use the returned authentication context, they can treat an unauthorized certificate as authorized, causing improper authentication. @grpc/grpc-js-xds can reach this condition when RBAC authentication is enabled in affected configurations. This issue is fixed in version 1.14.5 and 1.13.6.

    • Actualiza a 1.13.6
    • Actualiza a 1.14.5
    Publicación Actualización
  2. CVE-2026-101915

    Baja · CVSS 3.7EPSS 0,25%Corrección disponible

    @grpc/grpc-js: The server transmits some error messages thrown by method handlers to the client in status messages

    @grpc/grpc-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.13.6 and 1.14.5, when an application method handler throws an uncaught error, the server includes its error message in the status message sent to the client. The thrown error message is transmitted to the client, causing sensitive information disclosure when the message contains sensitive data. This issue is fixed in versions 1.13.6 and 1.14.5.

    • Actualiza a 1.13.6
    • Actualiza a 1.14.5
    Publicación Actualización
  3. CVE-2026-48069

    Alta · CVSS 7.5EPSS 0,88%Corrección disponible

    @grpc/grps-js: An incoming malformed compressed message can cause a client or server crash

    @grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming compressed message can cause a client or server process that uses @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

    • Actualiza a 1.10.12
    • Actualiza a 1.11.4
    • Actualiza a 1.12.7
    • Actualiza a 1.13.5
    • Actualiza a 1.14.4
    • Actualiza a 1.9.16
    Publicación Actualización
  4. CVE-2026-48068

    Alta · CVSS 7.5EPSS 0,88%Corrección disponible

    @grpc/grps-js: A malformed request can cause a server crash

    @grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

    • Actualiza a 1.10.12
    • Actualiza a 1.11.4
    • Actualiza a 1.12.7
    • Actualiza a 1.13.5
    • Actualiza a 1.14.4
    • Actualiza a 1.9.16
    Publicación Actualización
  5. CVE-2024-37168

    Media · CVSS 5.3EPSS 0,67%Corrección disponible

    @grpc/grpc-js can allocate memory for incoming messages well above configured limits

    @grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to versions 1.10.9, 1.9.15, and 1.8.22, there are two separate code paths in which memory can be allocated per message in excess of the `grpc.max_receive_message_length` channel option: If an incoming message has a size on the wire greater than the configured limit, the entire message is buffered before it is discarded; and/or if an incoming message has a size within the limit on the wire but decompresses to a size greater than the limit, the entire message is decompressed into memory, and on the server is not discarded. This has been patc

    • Actualiza a 1.10.9
    • Actualiza a 1.8.22
    • Actualiza a 1.9.15
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →