p PatchFirst

CVE-2026-48068

CVE-2026-48068 · @grpc/grps-js: A malformed request can cause a server crash

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming HTTP/2 stream initiation can cause a server process created using @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

CVSS 7.5 · Alta · EPSS 0,9% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • grpc-node

    Versiones
    • < 1.9.16: Afectada
    • >= 1.11.0, < 1.11.4: Afectada
    • >= 1.12.0, < 1.12.7: Afectada
    • >= 1.13.0, < 1.13.5: Afectada
    • >= 1.14.0, < 1.14.4: Afectada
    • >= 1.10.0, < 1.10.12: Afectada

    Sin corrección publicada

  • @grpc/grpc-js npm

    Intervalos de versiones afectados
    • SEMVER: < 1.9.16

    Actualiza a 1.9.16

  • @grpc/grpc-js npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.10.0, < 1.10.12

    Actualiza a 1.10.12

  • @grpc/grpc-js npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.11.0, < 1.11.4

    Actualiza a 1.11.4

  • @grpc/grpc-js npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.12.0, < 1.12.7

    Actualiza a 1.12.7

  • @grpc/grpc-js npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.13.0, < 1.13.5

    Actualiza a 1.13.5

  • @grpc/grpc-js npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.14.0, < 1.14.4

    Actualiza a 1.14.4

Fuentes originales

Comprueba tu servidor →