p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de content-security-policy-parser

Vulnerabilidades publicadas para content-security-policy-parser en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidad: 1

  1. CVE-2025-55164

    Alta · CVSS 8.8EPSS 0,47%Corrección disponible

    content-security-policy-parser Prototype Pollution Vulnerability May Lead to RCE

    content-security-policy-parser parses content security policy directives. A prototype pollution vulnerability exists in versions 0.5.0 and earlier, wherein if a policy name is called __proto__, one can override the Object prototype. This issue has been patched in version 0.6.0. A workaround involves disabling prototype method in NodeJS, neutralizing all possible prototype pollution attacks. Provide either --disable-proto=delete (recommended) or --disable-proto=throw as an argument to node to enable this feature.

    • Actualiza a 0.6.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →