p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de content-security-policy-parser

Vulnérabilité publiée pour content-security-policy-parser au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilité : 1

  1. CVE-2025-55164

    Élevée · CVSS 8.8EPSS 0,47%Correctif disponible

    content-security-policy-parser Prototype Pollution Vulnerability May Lead to RCE

    content-security-policy-parser parses content security policy directives. A prototype pollution vulnerability exists in versions 0.5.0 and earlier, wherein if a policy name is called __proto__, one can override the Object prototype. This issue has been patched in version 0.6.0. A workaround involves disabling prototype method in NodeJS, neutralizing all possible prototype pollution attacks. Provide either --disable-proto=delete (recommended) or --disable-proto=throw as an argument to node to enable this feature.

    • Mettez à jour vers 0.6.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →