p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de opencode-ai

Vulnerabilidades publicadas para opencode-ai en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2026-22813

    Crítica · CVSS 9.4EPSS 0,91%Corrección disponible

    Malicious website can execute commands on the local system through XSS in the OpenCode web UI

    OpenCode is an open source AI coding agent. The markdown renderer used for LLM responses will insert arbitrary HTML into the DOM. There is no sanitization with DOMPurify or even a CSP on the web interface to prevent JavaScript execution via HTML injection. This means controlling the LLM response for a chat session gets JavaScript execution on the http://localhost:4096 origin. This vulnerability is fixed in 1.1.10.

    • Actualiza a 1.1.10
    Publicación Actualización
  2. CVE-2026-22812

    Alta · CVSS 8.8EPSS 16,54%Código de explotación públicoCorrección disponible

    OpenCode's Unauthenticated HTTP Server Allows Arbitrary Command Execution

    OpenCode is an open source AI coding agent. Prior to 1.0.216, OpenCode automatically starts an unauthenticated HTTP server that allows any local process (or any website via permissive CORS) to execute arbitrary shell commands with the user's privileges. This vulnerability is fixed in 1.0.216.

    • Actualiza a 1.0.216
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →