p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de opencode-ai

Vulnérabilité publiée pour opencode-ai au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. CVE-2026-22813

    Critique · CVSS 9.4EPSS 0,91%Correctif disponible

    Malicious website can execute commands on the local system through XSS in the OpenCode web UI

    OpenCode is an open source AI coding agent. The markdown renderer used for LLM responses will insert arbitrary HTML into the DOM. There is no sanitization with DOMPurify or even a CSP on the web interface to prevent JavaScript execution via HTML injection. This means controlling the LLM response for a chat session gets JavaScript execution on the http://localhost:4096 origin. This vulnerability is fixed in 1.1.10.

    • Mettez à jour vers 1.1.10
    Publication Mise à jour
  2. CVE-2026-22812

    Élevée · CVSS 8.8EPSS 16,54%Code d’exploitation publicCorrectif disponible

    OpenCode's Unauthenticated HTTP Server Allows Arbitrary Command Execution

    OpenCode is an open source AI coding agent. Prior to 1.0.216, OpenCode automatically starts an unauthenticated HTTP server that allows any local process (or any website via permissive CORS) to execute arbitrary shell commands with the user's privileges. This vulnerability is fixed in 1.0.216.

    • Mettez à jour vers 1.0.216
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →