p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de sequelize

Vulnerabilidades publicadas para sequelize en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 18

  1. CVE-2026-69240

    Crítica · CVSS 9.8EPSS 0,54%Corrección disponible

    Sequelize: SQL Injection (Oracle DB)

    Sequelize is a Node.js ORM tool. Prior to 6.37.4, SQL injection is possible with strings only if dialect is set to oracle. The escape function defined in sql-string.js does not escape quotes if the value starts with TO_TIMESTAMP or TO_DATE. In the Oracle dialect, when val is a string and starts with TO_TIMESTAMP or TO_DATE, escape returns val directly instead of replacing single quotes. An attacker can inject arbitrary SQL expressions through an application value that reaches this escape path. This issue is fixed in version 6.37.4.

    • Actualiza a 6.37.4
    Publicación Actualización
  2. CVE-2026-30951

    Alta · CVSS 7.5EPSS 0,45%Corrección disponible

    Sequelize v6 Vulnerable to SQL Injection via JSON Column Cast Type

    Sequelize is a Node.js ORM tool. Prior to 6.37.8, there is SQL injection via unescaped cast type in JSON/JSONB where clause processing. The _traverseJSON() function splits JSON path keys on :: to extract a cast type, which is interpolated raw into CAST(... AS <type>) SQL. An attacker who controls JSON object keys can inject arbitrary SQL and exfiltrate data from any table. This vulnerability is fixed in 6.37.8.

    • Actualiza a 6.37.8
    Publicación Actualización
  3. CVE-2023-25813

    Crítica · CVSS 10EPSS 1,44%Corrección disponible

    SQL Injection via replacements in sequelize

    Sequelize is a Node.js ORM tool. In versions prior to 6.19.1 a SQL injection exploit exists related to replacements. Parameters which are passed through replacements are not properly escaped which can lead to arbitrary SQL injection depending on the specific queries in use. The issue has been fixed in Sequelize 6.19.1. Users are advised to upgrade. Users unable to upgrade should not use the `replacements` and the `where` option in the same query.

    • Actualiza a 6.19.1
    Publicación Actualización
  4. GHSA-fw4p-36j9-rrj3

    Sin evaluarCorrección disponible

    Denial of Service in sequelize

    Versions of `sequelize` prior to 4.44.4 are vulnerable to Denial of Service (DoS). The SQLite dialect fails to catch a `TypeError` exception for the `results` variable. The `results` value may be undefined and trigger the error on a `.map` call. This may allow attackers to submit malicious input that forces the exception and crashes the Node process. The following proof-of-concept crashes the Node process: ``` const Sequelize = require('sequelize'); const sequelize = new Sequelize({ dialect: 'sqlite', storage: 'database.sqlite' }); const TypeError = sequelize.define('TypeError', { name: Sequelize.STRING, }); TypeError.sync({force:

    • Actualiza a 4.44.4
    Publicación Actualización
  5. CVE-2016-1000225

    Crítica · CVSS 9.8Corrección disponible

    SQL Injection via GeoJSON in sequelize

    Affected versions of `sequelize` are vulnerable to SQL Injection in Models that have fields with the `GEOMETRY` DataType. This vulnerability occurs because single quotes in document values are not escaped for GeoJSON documents using `ST_GeomFromGeoJSON`, and MySQL GeoJSON documents using `GeomFromText`. ## Recommendation Update to version 3.23.6 or later.

    • Actualiza a 3.23.6
    Publicación Actualización
  6. CVE-2019-10752

    Crítica · CVSS 9.8EPSS 1,46%Corrección disponible

    CVE-2019-10752

    Sequelize, all versions prior to version 4.44.3 and 5.15.1, is vulnerable to SQL Injection due to sequelize.json() helper function not escaping values properly when formatting sub paths for JSON queries for MySQL, MariaDB and SQLite.

    • Actualiza a 4.44.3
    • Actualiza a 5.15.1
    Publicación Actualización
  7. GHSA-wfp9-vr4j-f49j

    Sin evaluarCorrección disponible

    NoSQL Injection in sequelize

    Versions of `sequelize` prior to 4.12.0 are vulnerable to NoSQL Injection. Query operators such as `$gt` are not properly sanitized and may allow an attacker to alter data queries, leading to NoSQL Injection. ## Recommendation Upgrade to version 4.12.0 or later

    • Actualiza a 4.12.0
    Publicación Actualización
  8. CVE-2016-10554

    Sin evaluarEPSS 1,88%Corrección disponible

    CVE-2016-10554

    sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS. Before version 1.7.0-alpha3, sequelize defaulted SQLite to use MySQL backslash escaping, even though SQLite uses Postgres escaping.

    • Actualiza a 1.7.0
    Publicación Actualización
  9. CVE-2016-10553

    Sin evaluarEPSS 1,26%Corrección disponible

    CVE-2016-10553

    sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS. A fix was pushed out that fixed potential SQL injection in sequelize 2.1.3 and earlier.

    • Actualiza a 3.0.0
    Publicación Actualización
  10. CVE-2016-10550

    Sin evaluarEPSS 1,88%Corrección disponible

    CVE-2016-10550

    sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS If user input goes into the `limit` or `order` parameters, a malicious user can put in their own SQL statements. This affects sequelize 3.16.0 and earlier.

    • Actualiza a 3.17.0
    Publicación Actualización
  11. CVE-2016-10556

    Alta · CVSS 7.5EPSS 1,32%Corrección disponible

    CVE-2016-10556

    sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS In Postgres, SQLite, and Microsoft SQL Server there is an issue where arrays are treated as strings and improperly escaped. This causes potential SQL injection in sequelize 3.19.3 and earlier, where a malicious user could put `["test", "'); DELETE TestTable WHERE Id = 1 --')"]` inside of ``` database.query('SELECT * FROM TestTable WHERE Name IN (:names)', { replacements: { names: directCopyOfUserInput } }); ``` and cause the SQL statement to become `SELECT Id FROM Table WHERE Na

    • Actualiza a 3.20.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →