p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de sequelize

Vulnérabilité publiée pour sequelize au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 18

  1. CVE-2026-69240

    Critique · CVSS 9.8EPSS 0,54%Correctif disponible

    Sequelize: SQL Injection (Oracle DB)

    Sequelize is a Node.js ORM tool. Prior to 6.37.4, SQL injection is possible with strings only if dialect is set to oracle. The escape function defined in sql-string.js does not escape quotes if the value starts with TO_TIMESTAMP or TO_DATE. In the Oracle dialect, when val is a string and starts with TO_TIMESTAMP or TO_DATE, escape returns val directly instead of replacing single quotes. An attacker can inject arbitrary SQL expressions through an application value that reaches this escape path. This issue is fixed in version 6.37.4.

    • Mettez à jour vers 6.37.4
    Publication Mise à jour
  2. CVE-2026-30951

    Élevée · CVSS 7.5EPSS 0,45%Correctif disponible

    Sequelize v6 Vulnerable to SQL Injection via JSON Column Cast Type

    Sequelize is a Node.js ORM tool. Prior to 6.37.8, there is SQL injection via unescaped cast type in JSON/JSONB where clause processing. The _traverseJSON() function splits JSON path keys on :: to extract a cast type, which is interpolated raw into CAST(... AS <type>) SQL. An attacker who controls JSON object keys can inject arbitrary SQL and exfiltrate data from any table. This vulnerability is fixed in 6.37.8.

    • Mettez à jour vers 6.37.8
    Publication Mise à jour
  3. CVE-2023-25813

    Critique · CVSS 10EPSS 1,44%Correctif disponible

    SQL Injection via replacements in sequelize

    Sequelize is a Node.js ORM tool. In versions prior to 6.19.1 a SQL injection exploit exists related to replacements. Parameters which are passed through replacements are not properly escaped which can lead to arbitrary SQL injection depending on the specific queries in use. The issue has been fixed in Sequelize 6.19.1. Users are advised to upgrade. Users unable to upgrade should not use the `replacements` and the `where` option in the same query.

    • Mettez à jour vers 6.19.1
    Publication Mise à jour
  4. GHSA-fw4p-36j9-rrj3

    Non évaluéeCorrectif disponible

    Denial of Service in sequelize

    Versions of `sequelize` prior to 4.44.4 are vulnerable to Denial of Service (DoS). The SQLite dialect fails to catch a `TypeError` exception for the `results` variable. The `results` value may be undefined and trigger the error on a `.map` call. This may allow attackers to submit malicious input that forces the exception and crashes the Node process. The following proof-of-concept crashes the Node process: ``` const Sequelize = require('sequelize'); const sequelize = new Sequelize({ dialect: 'sqlite', storage: 'database.sqlite' }); const TypeError = sequelize.define('TypeError', { name: Sequelize.STRING, }); TypeError.sync({force:

    • Mettez à jour vers 4.44.4
    Publication Mise à jour
  5. CVE-2016-1000225

    Critique · CVSS 9.8Correctif disponible

    SQL Injection via GeoJSON in sequelize

    Affected versions of `sequelize` are vulnerable to SQL Injection in Models that have fields with the `GEOMETRY` DataType. This vulnerability occurs because single quotes in document values are not escaped for GeoJSON documents using `ST_GeomFromGeoJSON`, and MySQL GeoJSON documents using `GeomFromText`. ## Recommendation Update to version 3.23.6 or later.

    • Mettez à jour vers 3.23.6
    Publication Mise à jour
  6. CVE-2019-10752

    Critique · CVSS 9.8EPSS 1,46%Correctif disponible

    CVE-2019-10752

    Sequelize, all versions prior to version 4.44.3 and 5.15.1, is vulnerable to SQL Injection due to sequelize.json() helper function not escaping values properly when formatting sub paths for JSON queries for MySQL, MariaDB and SQLite.

    • Mettez à jour vers 4.44.3
    • Mettez à jour vers 5.15.1
    Publication Mise à jour
  7. GHSA-wfp9-vr4j-f49j

    Non évaluéeCorrectif disponible

    NoSQL Injection in sequelize

    Versions of `sequelize` prior to 4.12.0 are vulnerable to NoSQL Injection. Query operators such as `$gt` are not properly sanitized and may allow an attacker to alter data queries, leading to NoSQL Injection. ## Recommendation Upgrade to version 4.12.0 or later

    • Mettez à jour vers 4.12.0
    Publication Mise à jour
  8. CVE-2016-10554

    Non évaluéeEPSS 1,88%Correctif disponible

    CVE-2016-10554

    sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS. Before version 1.7.0-alpha3, sequelize defaulted SQLite to use MySQL backslash escaping, even though SQLite uses Postgres escaping.

    • Mettez à jour vers 1.7.0
    Publication Mise à jour
  9. CVE-2016-10553

    Non évaluéeEPSS 1,26%Correctif disponible

    CVE-2016-10553

    sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS. A fix was pushed out that fixed potential SQL injection in sequelize 2.1.3 and earlier.

    • Mettez à jour vers 3.0.0
    Publication Mise à jour
  10. CVE-2016-10550

    Non évaluéeEPSS 1,88%Correctif disponible

    CVE-2016-10550

    sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS If user input goes into the `limit` or `order` parameters, a malicious user can put in their own SQL statements. This affects sequelize 3.16.0 and earlier.

    • Mettez à jour vers 3.17.0
    Publication Mise à jour
  11. CVE-2016-10556

    Élevée · CVSS 7.5EPSS 1,32%Correctif disponible

    CVE-2016-10556

    sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS In Postgres, SQLite, and Microsoft SQL Server there is an issue where arrays are treated as strings and improperly escaped. This causes potential SQL injection in sequelize 3.19.3 and earlier, where a malicious user could put `["test", "'); DELETE TestTable WHERE Id = 1 --')"]` inside of ``` database.query('SELECT * FROM TestTable WHERE Name IN (:names)', { replacements: { names: directCopyOfUserInput } }); ``` and cause the SQL statement to become `SELECT Id FROM Table WHERE Na

    • Mettez à jour vers 3.20.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →