p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de tar-fs

Vulnerabilidades publicadas para tar-fs en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 4

  1. CVE-2025-59343

    Alta · CVSS 8.7EPSS 0,55%Corrección disponible

    tar-fs has a symlink validation bypass if destination directory is predictable with a specific tarball

    tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.1.1, 2.1.3, and 1.16.5 are vulnerable to symlink validation bypass if the destination directory is predictable with a specific tarball. This issue has been patched in version 3.1.1, 2.1.4, and 1.16.6. A workaround involves using the ignore option on non files/directories.

    • Actualiza a 1.16.6
    • Actualiza a 2.1.4
    • Actualiza a 3.1.1
    Publicación Actualización
  2. CVE-2025-48387

    Alta · CVSS 8.7EPSS 0,58%Corrección disponible

    tar-fs has issue where extract can write outside the specified dir with a specific tarball

    tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.0.9, 2.1.3, and 1.16.5 have an issue where an extract can write outside the specified dir with a specific tarball. This has been patched in versions 3.0.9, 2.1.3, and 1.16.5. As a workaround, use the ignore option to ignore non files/directories.

    • Actualiza a 1.16.5
    • Actualiza a 2.1.3
    • Actualiza a 3.0.9
    Publicación Actualización
  3. CVE-2024-12905

    Alta · CVSS 7.5EPSS 2,3%Código de explotación públicoCorrección disponible

    CVE-2024-12905

    An Improper Link Resolution Before File Access ("Link Following") and Improper Limitation of a Pathname to a Restricted Directory ("Path Traversal"). This vulnerability occurs when extracting a maliciously crafted tar file, which can result in unauthorized file writes or overwrites outside the intended extraction directory. The issue is associated with index.js in the tar-fs package. This issue affects tar-fs: from 0.0.0 before 1.16.4, from 2.0.0 before 2.1.2, from 3.0.0 before 3.0.8.

    • Actualiza a 1.16.4
    • Actualiza a 2.1.2
    • Actualiza a 3.0.7
    Publicación Actualización
  4. CVE-2018-20835

    Alta · CVSS 7.5EPSS 2,36%Corrección disponible

    CVE-2018-20835

    A vulnerability was found in tar-fs before 1.16.2. An Arbitrary File Overwrite issue exists when extracting a tarball containing a hardlink to a file that already exists on the system, in conjunction with a later plain file with the same name as the hardlink. This plain file content replaces the existing file content.

    • Actualiza a 1.16.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →