CVE-2025-59343
CVE-2025-59343 · tar-fs has a symlink validation bypass if destination directory is predictable with a specific tarball
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.1.1, 2.1.3, and 1.16.5 are vulnerable to symlink validation bypass if the destination directory is predictable with a specific tarball. This issue has been patched in version 3.1.1, 2.1.4, and 1.16.6. A workaround involves using the ignore option on non files/directories.
CVSS 8.7 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
tar-fs
- Versiones
- >= 3.0.0, < 3.1.1: Afectada
- >= 2.0.0, < 2.1.3: Afectada
- < 1.16.5: Afectada
Sin corrección publicada
node-tar-fs Debian:12
- Versiones
- 2.1.1-6
- 2.1.3-0+deb12u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.3-0+deb12u2
Actualiza a 2.1.3-0+deb12u2
node-tar-fs Debian:13
- Versiones
- 3.0.9+~cs2.0.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1
Actualiza a 3.0.9+~cs2.0.4-1+deb13u1
node-tar-fs Debian:14
- Versiones
- 3.0.9+~cs2.0.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.9+~cs2.0.4-2
Actualiza a 3.0.9+~cs2.0.4-2
tar-fs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.0.0, < 3.1.1
Actualiza a 3.1.1
tar-fs npm
- Intervalos de versiones afectados
- SEMVER: ≥ 2.0.0, < 2.1.4
Actualiza a 2.1.4
tar-fs npm
- Intervalos de versiones afectados
- SEMVER: < 1.16.6
Actualiza a 1.16.6
node-tar-fs Ubuntu:Pro:22.04:LTS
- Versiones
- 2.1.1-2
- 2.1.1-4
- 2.1.1-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.1-6ubuntu0.22.04.1~esm1
Actualiza a 2.1.1-6ubuntu0.22.04.1~esm1
node-tar-fs Ubuntu:Pro:24.04:LTS
- Versiones
- 2.1.1-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.1-6ubuntu0.24.04.1~esm1
Actualiza a 2.1.1-6ubuntu0.24.04.1~esm1
node-tar-fs Ubuntu:25.10
- Versiones
- 2.1.1-6
- 3.0.8+~cs2.0.4-1
- 3.0.9+~cs2.0.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1
Actualiza a 3.0.9+~cs2.0.4-1+deb13u1build0.25.10.1