Laravel Cross-site Scripting vulnerability in blade templating
Laravel is prone to a Cross-site Scripting vulnerability in blade templating.
- Actualiza a 7.1.2
PatchFirst · Vulnerabilidades recientes
Vulnerabilidades publicadas para illuminate/view en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.
Vulnerabilidades: 2
Laravel is prone to a Cross-site Scripting vulnerability in blade templating.
Laravel is a web application framework. Laravel prior to versions 8.75.0, 7.30.6, and 6.20.42 contain a possible cross-site scripting (XSS) vulnerability in the Blade templating engine. A broken HTML element may be clicked and the user taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched in versions 8.75.0, 7.30.6, and 6.20.42 by determining the parent placeholder at runtime and using a random ha
Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.