p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de moodle/moodle · Página 10

Vulnerabilidades publicadas para moodle/moodle en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 437

  1. CVE-2021-43560

    Media · CVSS 5.3EPSS 1,13%Corrección disponible

    CVE-2021-43560

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. Insufficient capability checks made it possible to fetch other users' calendar action events.

    • Actualiza a 3.10.8
    • Actualiza a 3.11.4
    • Actualiza a 3.9.11
    Publicación Actualización
  2. CVE-2021-43559

    Alta · CVSS 8.8EPSS 0,62%Corrección disponible

    CVE-2021-43559

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. The "delete related badge" functionality did not include the necessary token check to prevent a CSRF risk.

    • Actualiza a 3.10.8
    • Actualiza a 3.11.4
    • Actualiza a 3.9.11
    Publicación Actualización
  3. CVE-2021-43558

    Media · CVSS 6.1EPSS 0,87%Corrección disponible

    CVE-2021-43558

    A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.

    • Actualiza a 3.10.8
    • Actualiza a 3.11.4
    • Actualiza a 3.9.11
    Publicación Actualización
  4. CVE-2021-21809

    Alta · CVSS 8.2EPSS 24,17%Código de explotación públicoSin corrección publicada

    CVE-2021-21809

    A command execution vulnerability exists in the default legacy spellchecker plugin in Moodle 3.10. A specially crafted series of HTTP requests can lead to command execution. An attacker must have administrator privileges to exploit this vulnerabilities.

    Publicación Actualización
  5. CVE-2021-20283

    Media · CVSS 4.3EPSS 1,11%Corrección disponible

    CVE-2021-20283

    The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

    • Actualiza a 3.10.2
    • Actualiza a 3.5.17
    • Actualiza a 3.8.8
    • Actualiza a 3.9.5
    Publicación Actualización
  6. CVE-2021-20282

    Media · CVSS 5.3EPSS 1,32%Corrección disponible

    CVE-2021-20282

    When creating a user account, it was possible to verify the account without having access to the verification email link/secret in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

    • Actualiza a 3.10.2
    • Actualiza a 3.5.17
    • Actualiza a 3.8.8
    • Actualiza a 3.9.5
    Publicación Actualización
  7. CVE-2021-20185

    Media · CVSS 5.3EPSS 1,39%Corrección disponible

    CVE-2021-20185

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.

    • Actualiza a 3.10.1
    • Actualiza a 3.5.16
    • Actualiza a 3.8.7
    • Actualiza a 3.9.4
    Publicación Actualización
  8. CVE-2021-20186

    Media · CVSS 5.4EPSS 0,76%Corrección disponible

    CVE-2021-20186

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of TeX content was required to prevent the risk of stored XSS.

    • Actualiza a 3.10.1
    • Actualiza a 3.5.16
    • Actualiza a 3.8.7
    • Actualiza a 3.9.4
    Publicación Actualización
  9. CVE-2021-20183

    Media · CVSS 5.4EPSS 0,83%Corrección disponible

    CVE-2021-20183

    It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search queries.

    • Actualiza a 4.0.0-beta
    Publicación Actualización
  10. CVE-2021-20187

    Alta · CVSS 7.2EPSS 1,59%Corrección disponible

    CVE-2021-20187

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.

    • Actualiza a 3.10.1
    • Actualiza a 3.5.16
    • Actualiza a 3.8.7
    • Actualiza a 3.9.4
    Publicación Actualización
  11. CVE-2020-25627

    Media · CVSS 6.1EPSS 3,72%Corrección disponible

    CVE-2020-25627

    The moodlenetprofile user profile field required extra sanitizing to prevent a stored XSS risk. This affects versions 3.9 to 3.9.1. Fixed in 3.9.2.

    • Actualiza a 3.9.2
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →