p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de prestashop/prestashop · Página 2

Vulnerabilidades publicadas para prestashop/prestashop en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 31

  1. CVE-2023-30838

    Alta · CVSS 8.6EPSS 1,04%Corrección disponible

    PrestaShop vulnerable to possible XSS injection through Validate::isCleanHTML method

    PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, the `ValidateCore::isCleanHTML()` method of Prestashop misses hijackable events which can lead to cross-site scripting (XSS) injection, allowed by the presence of pre-setup `@keyframes` methods. This XSS, which hijacks HTML attributes, can be triggered without any interaction by the visitor/administrator, which makes it as dangerous as a trivial XSS attack. Contrary to other attacks which target HTML attributes and are triggered without user interaction (such as onload / onerror which suffer from a very limited scope), this one can hijack every HTML

    • Actualiza a 1.7.8.9
    • Actualiza a 8.0.4
    Publicación Actualización
  2. CVE-2023-30545

    Alta · CVSS 7.7EPSS 0,86%Corrección disponible

    PrestaShop arbitrary file read vulnerability

    PrestaShop is an Open Source e-commerce web application. Prior to versions 8.0.4 and 1.7.8.9, it is possible for a user with access to the SQL Manager (Advanced Options -> Database) to arbitrarily read any file on the operating system when using SQL function `LOAD_FILE` in a `SELECT` request. This gives the user access to critical information. A patch is available in PrestaShop 8.0.4 and PS 1.7.8.9

    • Actualiza a 1.7.8.9
    • Actualiza a 8.0.4
    Publicación Actualización
  3. CVE-2023-25170

    Media · CVSS 5EPSS 0,22%Corrección disponible

    PrestaShop has possible CSRF token fixation

    PrestaShop is an open source e-commerce web application that, prior to version 8.0.1, is vulnerable to cross-site request forgery (CSRF). When authenticating users, PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enable same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. The problem is fixed in version 8.0.1.

    • Actualiza a 8.0.1
    Publicación Actualización
  4. CVE-2022-46158

    Media · CVSS 5.3EPSS 0,5%Corrección disponible

    Potential Information exposure in the upload directory in PrestaShop

    PrestaShop is an open-source e-commerce solution. Versions prior to 1.7.8.8 did not properly restrict host filesystem access for users. Users may have been able to view the contents of the upload directory without appropriate permissions. This issue has been addressed and users are advised to upgrade to version 1.7.8.8. There are no known workarounds for this issue.

    • Actualiza a 1.7.8.8
    Publicación Actualización
  5. CVE-2022-31181

    Crítica · CVSS 9.8EPSS 6,72%Código de explotación públicoCorrección disponible

    Remote code execution in prestashop

    PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.

    • Actualiza a 1.7.8.7
    Publicación Actualización
  6. CVE-2022-21686

    Crítica · CVSS 9EPSS 1,79%Corrección disponible

    Server Side Twig Template Injection in PrestaShop

    PrestaShop is an Open Source e-commerce platform. Starting with version 1.7.0.0 and ending with version 1.7.8.3, an attacker is able to inject twig code inside the back office when using the legacy layout. The problem is fixed in version 1.7.8.3. There are no known workarounds.

    • Actualiza a 1.7.8.3
    Publicación Actualización
  7. CVE-2021-43789

    Alta · CVSS 7.5EPSS 4,7%Corrección disponible

    Blind SQLi using Search filters in PrestaShop

    PrestaShop is an Open Source e-commerce web application. Versions of PrestaShop prior to 1.7.8.2 are vulnerable to blind SQL injection using search filters with `orderBy` and `sortOrder` parameters. The problem is fixed in version 1.7.8.2.

    • Actualiza a 1.7.8.2
    Publicación Actualización
  8. CVE-2019-11876

    Media · CVSS 6.1EPSS 0,89%Corrección disponible

    CVE-2019-11876

    In PrestaShop 1.7.5.2, the shop_country parameter in the install/index.php installation script/component is affected by Reflected XSS. Exploitation by a malicious actor requires the user to follow the initial stages of the setup (accepting terms and conditions) before executing the malicious link.

    • Actualiza a 1.7.6.0
    Publicación Actualización
  9. CVE-2018-20717

    Alta · CVSS 8.8EPSS 2,69%Corrección disponible

    CVE-2018-20717

    In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.

    • Actualiza a 1.7.2.5
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →