p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de silverstripe/graphql

Vulnerabilidades publicadas para silverstripe/graphql en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 8

  1. GHSA-wjg9-v8cf-f5q2

    Alta · CVSS 7.3Corrección disponible

    silverstripe/graphql Cross-Site Request Forgery vulnerability

    The GraphQL controller lacked any CSRF protection, meaning authenticated users could be forced or tricked into visiting a URL that would send a GET request to the affected web server that could mutate or destroy data without the user knowing.

    • Actualiza a 2.0.3
    Publicación Actualización
  2. CVE-2023-44401

    Media · CVSS 5.3EPSS 0,42%Corrección disponible

    Silverstripe GraqhQL's view permissions are bypassed for paginated lists of ORM data

    The Silverstripe CMS GraphQL Server serves Silverstripe data as GraphQL representations. In versions 4.0.0 prior to 4.3.7 and 5.0.0 prior to 5.1.3, `canView` permission checks are bypassed for ORM data in paginated GraphQL query results where the total number of records is greater than the number of records per page. Note that this also affects GraphQL queries which have a limit applied, even if the query isn’t paginated per se. This has been fixed in versions 4.3.7 and 5.1.3 by ensuring no new records are pulled in from the database after performing `canView` permission checks for each page of results. This may result in some pages in the qu

    • Actualiza a 4.3.7
    • Actualiza a 5.1.3
    Publicación Actualización
  3. CVE-2023-40180

    Alta · CVSS 7.5EPSS 1,13%Corrección disponible

    Denial of service vulnerability in silverstripe-graphql via recursive queries

    silverstripe-graphql is a package which serves Silverstripe data in GraphQL representations. An attacker could use a recursive graphql query to execute a Distributed Denial of Service attack (DDOS attack) against a website. This mostly affects websites with publicly exposed graphql schemas. If your Silverstripe CMS project does not expose a public facing graphql schema, a user account is required to trigger the DDOS attack. If your site is hosted behind a content delivery network (CDN), such as Imperva or CloudFlare, this may further mitigate the risk. This issue has been addressed in versions 3.8.2, 4.1.3, 4.2.5, 4.3.4, and 5.0.3. Users are

    • Actualiza a 3.8.2
    • Actualiza a 4.1.3
    • Actualiza a 4.2.5
    • Actualiza a 4.3.4
    • Actualiza a 5.0.3
    Publicación Actualización
  4. CVE-2023-28104

    Alta · CVSS 7.5EPSS 1,05%Corrección disponible

    silverstripe/graphql Denial of Service vulnerability

    `silverstripe/graphql` serves Silverstripe data as GraphQL representations. In versions 4.2.2 and 4.1.1, an attacker could use a specially crafted graphql query to execute a denial of service attack against a website which has a publicly exposed graphql endpoint. This mostly affects websites with particularly large/complex graphql schemas. Users should upgrade to `silverstripe/graphql` 4.2.3 or 4.1.2 to remedy the vulnerability.

    • Actualiza a 4.1.2
    • Actualiza a 4.2.3
    Publicación Actualización
  5. CVE-2020-6165

    Media · CVSS 5.3EPSS 1,07%Corrección disponible

    CVE-2020-6165

    SilverStripe 4.5.0 allows attackers to read certain records that should not have been placed into a result set. This affects silverstripe/recipe-cms. The automatic permission-checking mechanism in the silverstripe/graphql module does not provide complete protection against lists that are limited (e.g., through pagination), resulting in records that should have failed a permission check being added to the final result set. GraphQL endpoints are configured by default (e.g., for assets), but the admin/graphql endpoint is access protected by default. This limits the vulnerability to all authenticated users, including those with limited permission

    • Actualiza a 3.2.4
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →