p PatchFirst

CVE-2023-28104

CVE-2023-28104 · silverstripe/graphql Denial of Service vulnerability

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

`silverstripe/graphql` serves Silverstripe data as GraphQL representations. In versions 4.2.2 and 4.1.1, an attacker could use a specially crafted graphql query to execute a denial of service attack against a website which has a publicly exposed graphql endpoint. This mostly affects websites with particularly large/complex graphql schemas. Users should upgrade to `silverstripe/graphql` 4.2.3 or 4.1.2 to remedy the vulnerability.

CVSS 7.5 · Alta · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • silverstripe-graphql

    Versiones
    • = 4.1.1: Afectada
    • = 4.2.2: Afectada

    Sin corrección publicada

  • silverstripe/graphql Packagist

    Versiones
    • 4.1.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 4.1.1, < 4.1.2

    Actualiza a 4.1.2

  • silverstripe/graphql Packagist

    Versiones
    • 4.2.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 4.2.2, < 4.2.3

    Actualiza a 4.2.3

Fuentes originales

Comprueba tu servidor →