p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de simplesamlphp/saml2

Vulnerabilidades publicadas para simplesamlphp/saml2 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 9

  1. CVE-2026-49289

    Alta · CVSS 7.5EPSS 0,78%Corrección disponible

    SimpleSAMLphp SAML2: Possible DoS via XPath Transform

    The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. In 4.19.2 and 4.20.2, the library permits attacker-controlled XPath transforms while processing XML signatures in specially crafted SAML messages. XPath evaluation can consume uncontrolled processing resources, allowing a remote unauthenticated attacker to deny service to any entity relying on SimpleSAMLphp or directly on the SAML2 library. The mitigation limits the number of transforms, permits only transform algorithms identified by the SAML 2.0 Core specification, and specifically rejects XPath transforms. This issue is fixed in versions 4.19.3 and 4.20.3.

    • Actualiza a 4.19.3
    • Actualiza a 4.20.3
    Publicación Actualización
  2. CVE-2026-49283

    Alta · CVSS 8.7EPSS 0,47%Corrección disponible

    SimpleSAMLphp HTTP-Artifact TLS validator confusion allows cross-IdP authentication bypass

    The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.19.3, 4.20.2, 5.0.6, and 6.2.1, the HTTPArtifact::receive() flow can treat an unsigned embedded SAML Response as cryptographically valid for the wrong identity provider. SOAPClient::addSSLValidator() attaches a TLS-based validator to the outer SOAP ArtifactResponse, while the embedded Response receives a validator that delegates to the outer message and is later checked against metadata selected from the embedded response issuer rather than necessarily the artifact issuer. SOAPClient::validateSSL() returns normally when the TLS public key doe

    • Actualiza a 4.19.3
    • Actualiza a 4.20.2
    • Actualiza a 5.0.6
    • Actualiza a 6.2.1
    Publicación Actualización
  3. CVE-2025-27773

    Alta · CVSS 8.6EPSS 0,41%Corrección disponible

    SimpleSAMLphp SAML2 library has incorrect signature verification for HTTP-Redirect binding

    The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.17.0 and 5.0.0-alpha.20, there is a signature confusion attack in the HTTPRedirect binding. An attacker with any signed SAMLResponse via the HTTP-Redirect binding can cause the application to accept an unsigned message. Versions 4.17.0 and 5.0.0-alpha.20 contain a fix for the issue.

    • Actualiza a 4.17.0
    • Actualiza a 5.0.0-alpha.20
    Publicación Actualización
  4. CVE-2024-52806

    Alta · CVSS 8.3EPSS 0,43%Corrección disponible

    SimpleSAMLphp SAML2 has an XXE in parsing SAML messages

    SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 4.6.14 and 5.0.0-alpha.18.

    • Actualiza a 4.6.14
    Publicación Actualización
  5. CVE-2023-49087

    Media · CVSS 6.8EPSS 0,19%Corrección disponible

    Validation of SignedInfo

    xml-security is a library that implements XML signatures and encryption. Validation of an XML signature requires verification that the hash value of the related XML-document matches a specific DigestValue-value, but also that the cryptographic signature on the SignedInfo-tree (the one that contains the DigestValue) verifies and matches a trusted public key. If an attacker somehow (i.e. by exploiting a bug in PHP's canonicalization function) manages to manipulate the canonicalized version's DigestValue, it would be possible to forge the signature. This issue has been patched in version 1.6.12 and 5.0.0-alpha.13.

    • Actualiza a 5.0.0-alpha.13
    Publicación Actualización
  6. CVE-2018-7711

    Alta · CVSS 8.1EPSS 1,19%Corrección disponible

    CVE-2018-7711

    HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.

    • Actualiza a 1.10.6
    • Actualiza a 2.3.8
    • Actualiza a 3.1.4
    Publicación Actualización
  7. CVE-2018-7644

    Alta · CVSS 7.5EPSS 1,25%Corrección disponible

    CVE-2018-7644

    The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.

    • Actualiza a 1.10.5
    • Actualiza a 2.3.7
    • Actualiza a 3.1.3
    Publicación Actualización
  8. CVE-2018-6519

    Alta · CVSS 7.5EPSS 1,7%Corrección disponible

    CVE-2018-6519

    The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

    • Actualiza a 1.10.4
    • Actualiza a 2.3.5
    • Actualiza a 3.1.1
    Publicación Actualización
  9. CVE-2016-9814

    Crítica · CVSS 9.1EPSS 2,41%Corrección disponible

    CVE-2016-9814

    The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

    • Actualiza a 1.10.3
    • Actualiza a 1.8.1
    • Actualiza a 1.9.1
    • Actualiza a 2.3.3
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →