p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de simplesamlphp/saml2

Vulnérabilité publiée pour simplesamlphp/saml2 au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 9

  1. CVE-2026-49289

    Élevée · CVSS 7.5EPSS 0,78%Correctif disponible

    SimpleSAMLphp SAML2: Possible DoS via XPath Transform

    The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. In 4.19.2 and 4.20.2, the library permits attacker-controlled XPath transforms while processing XML signatures in specially crafted SAML messages. XPath evaluation can consume uncontrolled processing resources, allowing a remote unauthenticated attacker to deny service to any entity relying on SimpleSAMLphp or directly on the SAML2 library. The mitigation limits the number of transforms, permits only transform algorithms identified by the SAML 2.0 Core specification, and specifically rejects XPath transforms. This issue is fixed in versions 4.19.3 and 4.20.3.

    • Mettez à jour vers 4.19.3
    • Mettez à jour vers 4.20.3
    Publication Mise à jour
  2. CVE-2026-49283

    Élevée · CVSS 8.7EPSS 0,47%Correctif disponible

    SimpleSAMLphp HTTP-Artifact TLS validator confusion allows cross-IdP authentication bypass

    The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.19.3, 4.20.2, 5.0.6, and 6.2.1, the HTTPArtifact::receive() flow can treat an unsigned embedded SAML Response as cryptographically valid for the wrong identity provider. SOAPClient::addSSLValidator() attaches a TLS-based validator to the outer SOAP ArtifactResponse, while the embedded Response receives a validator that delegates to the outer message and is later checked against metadata selected from the embedded response issuer rather than necessarily the artifact issuer. SOAPClient::validateSSL() returns normally when the TLS public key doe

    • Mettez à jour vers 4.19.3
    • Mettez à jour vers 4.20.2
    • Mettez à jour vers 5.0.6
    • Mettez à jour vers 6.2.1
    Publication Mise à jour
  3. CVE-2025-27773

    Élevée · CVSS 8.6EPSS 0,41%Correctif disponible

    SimpleSAMLphp SAML2 library has incorrect signature verification for HTTP-Redirect binding

    The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.17.0 and 5.0.0-alpha.20, there is a signature confusion attack in the HTTPRedirect binding. An attacker with any signed SAMLResponse via the HTTP-Redirect binding can cause the application to accept an unsigned message. Versions 4.17.0 and 5.0.0-alpha.20 contain a fix for the issue.

    • Mettez à jour vers 4.17.0
    • Mettez à jour vers 5.0.0-alpha.20
    Publication Mise à jour
  4. CVE-2024-52806

    Élevée · CVSS 8.3EPSS 0,43%Correctif disponible

    SimpleSAMLphp SAML2 has an XXE in parsing SAML messages

    SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 4.6.14 and 5.0.0-alpha.18.

    • Mettez à jour vers 4.6.14
    Publication Mise à jour
  5. CVE-2023-49087

    Moyenne · CVSS 6.8EPSS 0,19%Correctif disponible

    Validation of SignedInfo

    xml-security is a library that implements XML signatures and encryption. Validation of an XML signature requires verification that the hash value of the related XML-document matches a specific DigestValue-value, but also that the cryptographic signature on the SignedInfo-tree (the one that contains the DigestValue) verifies and matches a trusted public key. If an attacker somehow (i.e. by exploiting a bug in PHP's canonicalization function) manages to manipulate the canonicalized version's DigestValue, it would be possible to forge the signature. This issue has been patched in version 1.6.12 and 5.0.0-alpha.13.

    • Mettez à jour vers 5.0.0-alpha.13
    Publication Mise à jour
  6. CVE-2018-7711

    Élevée · CVSS 8.1EPSS 1,19%Correctif disponible

    CVE-2018-7711

    HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.

    • Mettez à jour vers 1.10.6
    • Mettez à jour vers 2.3.8
    • Mettez à jour vers 3.1.4
    Publication Mise à jour
  7. CVE-2018-7644

    Élevée · CVSS 7.5EPSS 1,25%Correctif disponible

    CVE-2018-7644

    The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.

    • Mettez à jour vers 1.10.5
    • Mettez à jour vers 2.3.7
    • Mettez à jour vers 3.1.3
    Publication Mise à jour
  8. CVE-2018-6519

    Élevée · CVSS 7.5EPSS 1,7%Correctif disponible

    CVE-2018-6519

    The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

    • Mettez à jour vers 1.10.4
    • Mettez à jour vers 2.3.5
    • Mettez à jour vers 3.1.1
    Publication Mise à jour
  9. CVE-2016-9814

    Critique · CVSS 9.1EPSS 2,41%Correctif disponible

    CVE-2016-9814

    The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

    • Mettez à jour vers 1.10.3
    • Mettez à jour vers 1.8.1
    • Mettez à jour vers 1.9.1
    • Mettez à jour vers 2.3.3
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →